WebService radtreeview nodes -> NodeClick

2 posts, 0 answers
  1. Lukrs
    Lukrs avatar
    39 posts
    Member since:
    Sep 2012

    Posted 16 Jul 2012 Link to this post

    Hi Telerik,

    I have a problem with RadTreeView for a few days now. I am unable to find a reasonable explanation to this.

    In the attached file I have sent you the souce code of my problem.

    I have read in the following post, that the thing has been solved...

    But I still have a problem...the web service created nodes do not trigger server side NodeClick event.

    Please be so kind, and look into my code...it is really simple, but it doesn't work:)

    Taught I should add the web service too....the treeview has only two levels, and only the second level is populated through web service

    The rad controls version is RadControls for ASP.NET AJAX Q1 2011 NET 4.0

    Thanks in advance,

  2. Bozhidar
    Bozhidar avatar
    1095 posts

    Posted 19 Jul 2012 Link to this post

    Hi Luka,

    I tested the scenario, but everything is working correctly on my end. I've attached a small sample page where I have a TreeView with WebService LoadOnDemand and a NodeClick event attached to it. The event fires as expected for the new nodes. 

    All the best,
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. DevCraft R3 2016 release webinar banner
Back to Top