WebResource.axd files are not caching in Q1 2007

3 posts, 0 answers
  1. Jason Maronge
    Jason Maronge avatar
    322 posts
    Member since:
    Jan 2005

    Posted 04 May 2007 Link to this post

    I was wondering if there was anything done to the embedded resources in the Q1 2007 release.  I am using CacheRight to control caching and in the Q4 2006 the WebResource.axd was being cached, but in the Q1 2007 version of the controls it is not.  The Q1 2007 controls are showing private in fiddler for the caching header.  Here is what fiddler is telling me about the caching header.

    Q4 2006:

    GET /DocuView/WebResource.axd?d=3y2KDMTbDnUGRs4XPQBQZTV0Sg50RQXGsqDy75iEPz2K8KJYYboLMC-WO1e32vLxrKbhrFqn23lgOYXd4AgPFunREWx7sKqT7oXFd0aZjwzOimOHRjNcwsGFZak0Y6uN0&t=633053219380000000 HTTP/1.1

    HTTP/1.0 Expires Header is present: Sat, 03 May 2008 15:21:31 GMT
    HTTP/1.1 Cache-Control Header is present: public
     public: This response MAY be cached by any cache.
    HTTP/1.1 Vary Header is present: Accept-Encoding

    Q1 2007: 

    GET /DocuView/WebResource.axd?d=iiE3DwOqePpARqtJ4HIHwnicQzhfxWyJtQmCjTIAgHdpnHH9Krp57R14Ygf-R9MP0-jRXypOzCMGpmlhNhvFq4ZwvVXYZBSqzo7KoaHmwUOHQRR-RjJKPlK8QsR4Z9be0&t=633130962220000000 HTTP/1.1

    HTTP/1.1 Cache-Control Header is present: private
    HTTP/1.1 Vary Header is present: Accept-Encoding

    I thought that maybe the HTTP/1.0 line had something to do with it but it appears on all the files expect the WebResource.axd.  This is a problem because it is always having to download the webresource files now.  I am using the same rules file for both servers so that is not the problem. 

    Thanks,

    Jason

  2. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 07 May 2007 Link to this post

    Hi Jason,

    This side effect might be related to WebResource caching - when your website is in debug mode (<compilation debug="true" /> in web.config) files streamed by WebResource.axd are not cached by the browser.

    Here is a nice blog post on that matter:
    http://ocegtech.blogspot.com/2006/06/aspnet-20-webresourceaxd-and-browser.html

    In a word everything should be ok once the site is not in debug mode (<compilation debug="false" />).

    Let me know whether this helps.

    Kind regards,
    Paul
    the telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Jason Maronge
    Jason Maronge avatar
    322 posts
    Member since:
    Jan 2005

    Posted 07 May 2007 Link to this post

    I went back this morning to check the debug flag on the test server and it was set to false so I decided to run the app again and now it seems like it is caching.  :)  I guess the gremlins decided to leave this weekend.

    Jason
Back to Top