Web.config registration missing! in Editor

4 posts, 0 answers
  1. Gaurav
    Gaurav avatar
    7 posts
    Member since:
    Jul 2011

    Posted 29 Jul 2011 Link to this post

    Hi,

    I am working with RadEditor. I have purchased premium controls pack.
    Editor works fine but when we open a image manager it throw an error i.e.

    Web.config registration missing!
     The Telerik dialogs require a HttpHandler registration in the web.config file. Please, use the control's Smart Tag to add the handler automatically, or see the help for more information: Controls > RadEditor > Dialogs > Introduction

    My webconfig file code is :

    <system.web>
     <httpHandlers>
          <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" />
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
          <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" validate="false" />
        </httpHandlers>
        <httpModules>
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" />
        </httpModules>
      </system.web>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <handlers>
          <add name="Telerik.Web.UI.DialogHandler.aspx" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" />
        </handlers>
        <modules runAllManagedModulesForAllRequests="true">
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" preCondition="managedHandler" />
        </modules>
      </system.webServer>
    </configuration>

    and i am using routing without MVC architecture with asp.net 4.0 framework. and in global.asax file code is here

     routes.Ignore("{resource}.axd/{*pathInfo}");
    routes.Ignore("Telerik.Web.UI.DialogHandler.aspx");

    ignore for telerik controls.

    these all code works fine in visual studio and run site from visual studio.

    but it throws error while we run this site in IIS 7.0 or IIS 7.5.

    and it shows a alert message and image manager page displays :

    HTTP Error 500.21 - Internal Server Error

    Handler "Telerik.Web.UI.DialogHandler.aspx" has a bad module "ManagedPipelineHandler" in its module list


    message

    How to resolve this error?????
  2. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 03 Aug 2011 Link to this post

    Hi Gaurav,

    If this line
    routes.Ignore("{resource}.axd/{*pathInfo}")

    skips (ignores) the *.axd handlers from the URL routing, you can open the web.config file and replace all instances of Telerik.Web.UI.DialogHandler.aspx with Telerik.Web.UI.DialogHandler.axd

    Web.config:
    ...
    <httpHandlers>
           <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
    ...
    </httpHandlers>
    ...
    <handlers>
        <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" />
    ...
    </handlers>
    ...

    After that set the RadEditor's DialogHandlerUrl property to "~/Telerik.Web.UI.DialogHandler.axd".

    Best regards,
    Rumen
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Mark Kucera
    Mark Kucera avatar
    84 posts
    Member since:
    Sep 2009

    Posted 08 Mar 2012 Link to this post

    I'm having this same exact problem in IIS 7.5.  The screenshots are identical to what the original poster provided, except that I'm using .Net 2.0 instead of .Net 4.0, so i don't have those settings that the original poster had in his global.asax.  I'm not sure what i'm supposed to change in my web.config because the same site/code is working fine in IIS6.

    Thanks!
    -Mark

    mkucera at whatcounts.com
  5. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 13 Mar 2012 Link to this post

    Hi,

    Please, try the suggestion in the following help article for IIS7.5: Registering the HttpHandlers on Windows Vista IIS 7 Integrated mode.

    Best regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top