Want to disabled all the animation of modal view and popover

7 posts, 0 answers
  1. jahanzaib
    jahanzaib avatar
    7 posts
    Member since:
    Mar 2016

    Posted 31 Mar Link to this post

    I need to disabled all the animation on opening and close of  Modalview and 
    popover I used your windows.kendo.disabled function but it stopped my transition of view change.
     I searched this functionality in all your documentation but all in vain Side by side i need to know 
    that  keyboard opening in android dont shift the  screen or view above In this way I dont know what i m writing 

    Thanks 
  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 05 Apr Link to this post

    Hi,

    You can refer to this forum post on Kendo Mobile Modalview Animation. Basically, what I can suggest you is to configure: 
    $("#my-modal").data("kendoMobileModalView").shim.popup.options.animation.close.duration = 0;
    $("#my-modal").data("kendoMobileModalView").shim.popup.options.animation.open.duration = 0;

    Regards,
    Dimitrina
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. jahanzaib
    jahanzaib avatar
    7 posts
    Member since:
    Mar 2016

    Posted 10 Apr Link to this post

    Hi Dimitrina,

    Thanks for your reply for modalanimation  but i want to disable the animation of popover .I used the sameway like $("#my-modal").data("kendoMobilepopover").shim.popup.options.animation.open.duration = 0; but it is not working

  4. jahanzaib
    jahanzaib avatar
    7 posts
    Member since:
    Mar 2016

    Posted 10 Apr Link to this post

    Hi Dimitrina

    Thanks for your message on modalviewanimation but i want to remove the kendo animation of popover . I used the same way 

    $("#my-modal").data("kendoMobilepopover").shim.popup.options.animation.close.duration = 0; but it is not working

  5. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 14 Apr Link to this post

    Hi,

    Can you try removing the effects with the following code:
    $("#my-modal").data("kendoMobilepopover").shim.popup.options.animation.open.effects = "none";

    Let us know if this helps.

    Regards,
    Tina Stancheva
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. jahanzaib
    jahanzaib avatar
    7 posts
    Member since:
    Mar 2016

    Posted 18 Apr in reply to Tina Stancheva Link to this post

    hi tina

    Thanks for your answer but it is not working fade effect still coming 

  7. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 21 Apr Link to this post

    Hi,

    I am not sure I understand your requirements properly. I prepared a sample Telerik Dojo example.

    Please have a look at it and elaborate on the behavior you're expecting and how it differs from the one demonstrated in the sample.

    Regards,
    Tina Stancheva
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top