VS10 Datasource dropdown and MSFT controls

11 posts, 1 answers
  1. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 07 Feb 2010 Link to this post

    I'm still using VS2008 and RIA .Net 3.5, so my question is based on screen shots I've seen.

    I noticed from THIS screen shot when in VS10 you click on a datasource when developing RIA apps, it gives you a drop down of MSFT controls (which you customize by adding or removing). But my concern is that, on the customizing, you only get MSFT DataGrid or Combobox and etc. where Telerik also has it's own. So, if we want to use these new tools in VS10 to create forms, how can we use Telerik controls in these dropdown boxes?

    I'm planning to move to VS1 when it goes RC.
    Thanks!
    ..Ben
  2. Stefan Dobrev
    Admin
    Stefan Dobrev avatar
    790 posts

    Posted 08 Feb 2010 Link to this post

    Hi Ben,

    We have already placed the appropriate attributes in our design time assemblies in order to display our controls in this dialog. However with beta 2 version VS will not pick correctly our registered types and will not show RadGridView for example in the options. We will do further testing on this when the release candidate is out and make sure everything works as expected when VS 2010 is finally released.

    All the best,
    Stefan Dobrev
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  3. DevCraft banner
  4. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 08 Feb 2010 Link to this post

    Thanks Stefan for the good news. You guys are always ahead of us :-)
    I'll be switching over to VS10 at RC time too.
  5. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 08 Feb 2010 Link to this post

    Well, I made a call to MSFT and told them Telerik needs RC, and they said:
    http://msdn.microsoft.com/en-us/vstudio/dd582936.aspx
    :-)



  6. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 22 Mar 2010 Link to this post

    I'm about to start moving from VS2008 and MS grid to VS10 and Telerik and I just wanted to check back with the team if this issue has been resolved as of the latest Q1 Release?

    Thanks!
  7. Stefan Dobrev
    Admin
    Stefan Dobrev avatar
    790 posts

    Posted 23 Mar 2010 Link to this post

    Hi Ben,

    Yes we have placed the required attributes. You can check this blog post which illustrates how to customize the controls used by the data sources window.

    Greetings,
    Stefan Dobrev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  8. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 23 Mar 2010 Link to this post

    Thanks Stefan;

    Due to some issues I have now with ASP.Net 4 and VS10, I'm reinstalling VS10 again and then I'll try to manually add the Telerik SL4 RC controls (internal DLLs) to the toolbox. Should that do it or do we need to wait for the full install from Telerik for the RC in VS10?

    Thanks!
  9. Answer
    Stefan Dobrev
    Admin
    Stefan Dobrev avatar
    790 posts

    Posted 26 Mar 2010 Link to this post

    Hi Ben,

    Manually adding controls to the toolbox should work as well.

    Greetings,
    Stefan Dobrev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  10. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 26 Mar 2010 Link to this post

    Yes, I tested last night and worked. However, anytime I try to use the RAD RC controls on designer in VS or Blend, I get error related "Object Reference not set to an instance of an object" and Blend constantly complains about COM objects.
  11. Nikolay
    Admin
    Nikolay avatar
    3997 posts

    Posted 02 Apr 2010 Link to this post

    Hello ..Ben,

    We will be definitely looking into this and we will try to address the issue in some of the forthcoming Latest Internal Builds.

    Kind regards,
    Nick
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  12. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 02 Apr 2010 Link to this post

    Thanks Nick;

    Hopefully by SP1 it gets resolved once you have a full installation for SL4 controls. I suggest you guys wait till MS releases SL4, RIA, VS10 and .Net 4 and then give us a clean install for SP1.

    Thank you guys for all the hard and great work you all do to make our lives easier. :-)
    ..Ben
Back to Top
DevCraft banner