VS: 'OpenAccessDataSource' is not defined.

2 posts, 0 answers
  1. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 20 Sep 2011 Link to this post

    Hello,

    When adding the
    OpenAccessDataSource to my form I got and VS error: VS: 'OpenAccessDataSource' is not defined.

    (Also found / replied here: http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/openaccessdatasource-is-not-defined.aspx#1190901)

    Well, I ended up adding all the references I could think of, but no luck.

    I have a .net 4 web app. I added OpenAccess, OpenAccess.35.exten, OpenAccess.40.exten, OpenAccess.config, OpenAccess.Intellitrace, OpenAccess.Runtime, OpenAccess.SDK.Design, OpenAccess.Windows

    No luck. I've been trying to use the control for 2 years now and I have never been able to use it. Smart tag always wants me to compile, now this. Is it even a real control? :-)

    Erik
  2. Zoran
    Admin
    Zoran avatar
    534 posts

    Posted 22 Sep 2011 Link to this post

    Hello Erik,

     You need to add the Telerik.OpenAccess.Web assembly as a reference to your project in order to used the Web Datasource. However this control is indeed out-of-date and above all based on OQL. At the moment we are working on a new datasource control that will be much more capable than the existing one as it will be LINQ based. The Visual Studio integration will also be much smoother than the existing one. You can expect the new control in the upcoming Q3 release.

    Greetings,
    Zoran
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's SQL Server Community Awards. We are competing in TWO categories and every vote counts! VOTE for Telerik NOW >>

  3. DevCraft banner
Back to Top