Visual Style Builder Preview Mode Not Rendering

8 posts, 0 answers
  1. john-paul
    john-paul  avatar
    5 posts
    Member since:
    Nov 2008

    Posted 14 Dec 2008 Link to this post

    Hi,
    I can't seem to get the preview in the visual style builder to render my updates.  It always shows the default theme.
    Most of my testing has been with the GridView control.
    I'm running Vista, and Q3-2008 of Winforms.
    Thx,
    JP
  2. Nick
    Admin
    Nick avatar
    767 posts

    Posted 15 Dec 2008 Link to this post

    Hello john-paul ,

    Thank you for your question.

    Yes, we found this glitch ourselves during our regular tests of the Visual Style Builder. It involves only RadGridView updates - the rest of the controls are ok.

    We are working on the issue as we speak. Sorry for the introduced inconvenience. Do not hesitate to write me back if you have more questions.

    Sincerely yours,
    Nick
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for WinForms is Visual Studio 2017 Ready
  4. john-paul
    john-paul  avatar
    5 posts
    Member since:
    Nov 2008

    Posted 15 Dec 2008 Link to this post

    Thanks.

    What's the ETA?

    JP
  5. Nick
    Admin
    Nick avatar
    767 posts

    Posted 17 Dec 2008 Link to this post

    Hello john-paul,

    We plan to provide a fix in our next release in January. In case this is a show stopper, we can send you a custom build next week.

    Untiul then, you can temporarily install Q2 SP1 and use the VSB which comes in it. Since there are not changes in the theming mechanism between Q2 and Q3, you can style your grid with the older version, export the theme to XML and apply it to your Q3 project.

    Again, we are sorry for this. Do not hesitate to write me back if you have more questions.
     

    All the best,
    Nick
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. john-paul
    john-paul  avatar
    5 posts
    Member since:
    Nov 2008

    Posted 25 Jan 2009 Link to this post

    Hello,

    Has a fix been released for this yet?  I'll be needing to use this Theme Builder for my grids in the next week.

    Thanks,
    JP
  7. john-paul
    john-paul  avatar
    5 posts
    Member since:
    Nov 2008

    Posted 28 Jan 2009 Link to this post

    I see this has been fixed in the current release.  I'll give it a 'try
    Thx,
    JP
  8. Nikolay
    Admin
    Nikolay avatar
    1804 posts

    Posted 29 Jan 2009 Link to this post

    Hi john-paul ,

    Indeed, the issue with viewing your RadGridView theme in the Visual Style Builder was addressed in Q3 2008 SP2. There are some minor things to be improved, however the overall behavior is correct now.

    If you have additional questions, feel free to contact me.

    Best wishes,
    Nikolay
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. Stefan
    Admin
    Stefan avatar
    2890 posts

    Posted 17 Mar 2011 Link to this post

    Hello john-paul,

    I am glad to inform you that Q1 2011 is released and the VSB theme preview is greatly improved. Additionally, VSB has a functionality to start the newly introduced tool - ThemeViewer - which gives you the ability to preview the created theme of all RadControls for WinForms together. For more information refer to this blog post.

    Best wishes,
    Stefan
    the Telerik team
Back to Top
UI for WinForms is Visual Studio 2017 Ready