Visual Studio Extension 2016.2.727.2 Build and Deploy bug on iOS

4 posts, 1 answers
  1. Joe
    Joe avatar
    16 posts
    Member since:
    Jan 2013

    Posted 28 Jul Link to this post

    After yesterday's AppBuilder Visual Studio extension update, I can no longer run apps on iOS devices after deploying with the Build and Deploy context menu option. They hang on the splash screen with the following errors:

    iPad:

    ERROR: Start Page at 'file:///var/mobile/Containers/Data/Application/36E31505-79BE-4ED2-94F0-70678E2938D1/Library/Application%20Support/LiveSync/index.html' was not found.

    iPhone:
    ERROR: Start Page at 'file:///var/mobile/Containers/Data/Application/ECA81391-A44A-492B-90DA-B6AAFF18BB36/Library/Application%20Support/LiveSync/index.html' was not found.

    This is critical issue affecting my daily deployment and debugging developer experience with AppBuilder.

  2. Joe
    Joe avatar
    16 posts
    Member since:
    Jan 2013

    Posted 28 Jul Link to this post

    This error is not occurring with Release configuration builds, only debug. Debug mode sure is helpful for device livereload on file changes.
  3. Answer
    Aleksandar Hitrov
    Admin
    Aleksandar Hitrov avatar
    10 posts

    Posted 29 Jul Link to this post

    Hello Joe,

    Thank for reporting this issue. We have identified that the culprit is a problem in the AppBuilder LiveSync functionality which has some compatibility issues with the WKWebView. This functionality is enabled by a plugin which is automatically enabled when the app is built for debug. This is why apps built in release mode work fine.

    We have logged the issue in our bug tracking system and are actively working on providing a fix early next week.


    Apologies for the inconvenience and don't hesitate to contact us if you have any concerns or questions related to AppBuilder.

    Regards,
    Aleksandar Hitrov
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  4. Joe
    Joe avatar
    16 posts
    Member since:
    Jan 2013

    Posted 04 Aug in reply to Aleksandar Hitrov Link to this post

    It's working great again today. Thanks, Aleksandar!
Back to Top