Vista Skin and Height of Embedded Control

7 posts, 0 answers
  1. Seth
    Seth avatar
    90 posts
    Member since:
    Jun 2007

    Posted 01 Apr 2008 Link to this post

    I am using the PanelBar a RadTreeView embedded in one of the RadPanelItems.  The height of the tree is set to 100%.

    When I am using the Office2007 skin, it works just fine.  When I use the Vista skin, the tree height is only as large as the tree itself.  This is not a product of the tree as I am using another control in one of the other RadPanelItems and I get the same result.

    Is there a property in the CSS files that needs to be changed?

    Thanks.

    Seth
  2. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 02 Apr 2008 Link to this post

    Hi Seth,

    This is a known bug that is already fixed. The fix will be included in the official Q1 2008 release.

    Greetings,
    Paul
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Seth
    Seth avatar
    90 posts
    Member since:
    Jun 2007

    Posted 02 Apr 2008 Link to this post

    Is it a CSS change?  Is it something I can change myself without much hassle?  I am at a point in my project where I need to start doing demos and I'd like to have that part functioning the way it should for those demos...
  5. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 03 Apr 2008 Link to this post

    Hello Seth,

    I'm afraid the change is not that simple and we cannot give you any workaround.

    Sincerely yours,
    Paul
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Seth
    Seth avatar
    90 posts
    Member since:
    Jun 2007

    Posted 17 Apr 2008 Link to this post

    I have updated to the latest and official release of the toolkit in anticipation of this bug being fixed.  It does not appear to be fixed.  I uninstalled the previous installation and installed the new one and the problem is still there.

    What do I need to do?
  7. Rosi
    Admin
    Rosi avatar
    2527 posts

    Posted 18 Apr 2008 Link to this post

    Hello Seth,

    Everything worked as expected at our side. Please find attached a sample project illustrating it.

    If this does not help you, please open a support ticket and send us a running project to test locally.

    Regards,
    Rosi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. Seth
    Seth avatar
    90 posts
    Member since:
    Jun 2007

    Posted 18 Apr 2008 Link to this post

    Thank you for that test.

    Change your treeview skin to Office2007 and you will see the problem.

    My hope is that you will find the issue because I can use the default skin for the treeview, but I also have a 3rd party control that I am housing in the PanelBar and the Vista skin has the same effect on it.  If I use any of the other skins for the panelbar, everything functions the way I expect.

    FYI, the third party control is the WebThumbnailViewer from Atalasoft.

    Thanks.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017