Vertical TabControl - can't get rid of the border line

4 posts, 1 answers
  1. Michal
    Michal avatar
    9 posts
    Member since:
    Nov 2010

    Posted 11 Jan 2012 Link to this post

    Hi,

    I have a vertical tab control with TabStripPlacement  set to Left. In this scenario I get a unwanted gray line. (see TabControl StripLeft.PNG)

    When I change the code to tab strip placed on the Top it is correctly rendered with no line (see TabControl StripTop.PNG)

    Here is my xaml:
    <Grid x:Name="LayoutRoot">
     
        <telerik:RadTabControl Grid.Row="2"  TabStripPlacement="Left" TabOrientation="Vertical" Align="Right" >
            <telerik:RadTabItem Height="Auto" VerticalAlignment="Top" Header="Test 1"  >
                <Grid Background="White"></Grid>
            </telerik:RadTabItem>
         
            <telerik:RadTabItem Height="Auto" VerticalAlignment="Top" Header="Test 2"  >
                <Grid Background="White"></Grid>
            </telerik:RadTabItem>
        </telerik:RadTabControl>
    </Grid>
    How can I get rid of the gray line when the TabStripPlacement is set to Left?

    Mike

  2. Answer
    Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 12 Jan 2012 Link to this post

    Hi Michal,

    You can change the BorderThickness of the RadTabControl. By default its value is "1 0 1 1". And in your case, when setting the TabStripPlacement to Left, you can change the BorderThickness to "0 1 1 1".

    Please give this a try and let me know if it works for you.

    Kind regards,
    Tina Stancheva
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Michal
    Michal avatar
    9 posts
    Member since:
    Nov 2010

    Posted 12 Jan 2012 Link to this post

    That worked thank you.

    Maybe when you set the TabStripPlacement="Left" the BorderThicknes should be changed "0 1 1 1" automatically.

  5. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 17 Jan 2012 Link to this post

    Hello Michal,

    Our further investigation indicated that this is actually an issue in the control as it should automatically remove this border. But it seems some of the visual states of the control aren't properly applied. Therefore I logged an item in our PITS where you can track the progress of the issue.

    I also updated your Telerik account for bringing this case to our attention.

    All the best,
    Tina Stancheva
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top