Vertical scroll does not display all rows in RadGridView

2 posts, 0 answers
  1. vaishali12tathe
    vaishali12tathe avatar
    1 posts
    Member since:
    Feb 2014

    Posted 28 Feb 2014 Link to this post

    Hi,

    I am having a vertical scroll problem in RadGridView. Scroll is enabled to RadGridView, but vertical scroll bar does not scroll till end to show all the rows(items) bind to grid.
    But on deleting existing(visible) rows from grid makes the other(hidden) rows visible. I seems the data is bound to grid correctly but all items are not visible.
    If I enable the pagination to grid by using RadDataPager ...on last page I can see hidden rows also.
    Please can any one help me to resolve this issue.... Thanks in advance..

    CODE:
    <telerik:RadGridView x:Name="RadGridView1" Height="548"
    RowIndicatorVisibility="Collapsed" FontSize="13"  FontFamily="/StrategicPlanning;component/Fonts/Fonts.zip#Segoe UI"
    CanUserDeleteRows="True"  ShowGroupPanel="False"  AutoGenerateColumns="False"  CanUserFreezeColumns="True"
    CanUserInsertRows="True"  GridLinesVisibility="Both" BorderBrush="Gray" telerik:StyleManager.Theme="Windows7"
    CanUserResizeColumns="True"  CanUserReorderColumns="True"  EnableColumnVirtualization="True"
    RowDetailsVisibilityChanged="RadGridView1_RowDetailsVisibilityChanged" BeginningEdit="RadGridView1_BeginningEdit" RowEditEnded="RadGridView1_RowEditEnded"  Filtered="RadGridView1_Filtered" AddingNewDataItem="RadGridView1_AddingNewDataItem"
    Deleting="RadGridView1_Deleting" Deleted="RadGridView1_Deleted" ColumnReordered="RadGridView1_ColumnReordered"
    ColumnWidthChanged="RadGridView1_ColumnWidthChanged" EnableLostFocusSelectedState="False" DataLoaded="RadGridView1_DataLoaded" SelectionChanged="RadGridView1_SelectionChanged" Sorting="RadGridView1_Sorting" CellEditEnded="RadGridView1_CellEditEnded_1"
    IsReadOnlyBinding="{Binding IsItemReadOnly}">

    <telerik:RadGridView.Columns> 

        <telerik:GridViewDataColumn UniqueName="MedianAge" Header="Median Age" Width="100" DataMemberBinding="{Binding RelMedianAge}" ShowFieldFilters="False" ShowDistinctFilters="True" IsFilterable="True"/>
    <telerik:GridViewDataColumn UniqueName="MedianHouseholdIncome" Header="Median Household Income" Width="150" DataMemberBinding="{Binding RelMedianHouseholdIncome}" ShowFieldFilters="False" ShowDistinctFilters="True" IsFilterable="True"/>
    <telerik:GridViewDataColumn UniqueName="WhiteCollar" Header="White Collar" Width="150" DataMemberBinding="{Binding RelWhiteCollar}" ShowFieldFilters="False" ShowDistinctFilters="True" IsFilterable="True"/>
    <telerik:GridViewDataColumn UniqueName="GrossSqFootage" Header="Gross Sq. Footage" Width="150" DataMemberBinding="{Binding RelGrossSquareFootage}" ShowFieldFilters="False" ShowDistinctFilters="True" IsFilterable="True"/>
    <telerik:GridViewDataColumn UniqueName="LandlordAddress" Header="Landlord Address" Width="150" DataMemberBinding="{Binding RelLandlordAddress}" ShowFieldFilters="False" ShowDistinctFilters="True" IsFilterable="True"/> </telerik:RadGridView.Columns>
    </telerik:RadGridView>

    Thanks
    Vaishali Tathe
  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 28 Feb 2014 Link to this post

    Hi,

    May I ask you to test if you get the same behavior with our latest version - 2014 Q1? Another suggestion would be to test with the default Office_Black Theme. Do you still reproduce the issue?

    Regards,
    Didie
    Telerik
  3. DevCraft banner
Back to Top