Using WebAii 2010.3.1421.0 for FireFox4

7 posts, 0 answers
  1. Ivan
    Ivan avatar
    1 posts
    Member since:
    Mar 2011

    Posted 28 Mar 2011 Link to this post

    Hello Good people,

    I want to ask you if it's possible to use WebAii 2010.3.1421.0 to run automation tests in FireFox 4. I have been using it ever since it is available for running in IE9 and i met no problems. But i just can't seem to get it running on FF4. When i open FireFox and go to the addons it seems that the addon-s of WebAii are not enabled or something.

    Can i do something to run my tests with this version (for example how can i install and enable the WebAii addons for FF4)? If not could you tell me when i can expect a version of WebAii that supports FF4?

    Thanks

    Ivan
  2. Anthony
    Admin
    Anthony avatar
    19 posts

    Posted 28 Mar 2011 Link to this post

    Hello Ivan,

    Unfortunately the product is not currently compatible with Firefox 4. Our developers are aware of this and are busily working on a fix. A release date has not yet been determined, however.

    In the meantime we recommend downgrading to version 3.6.

    Best wishes,
    Anthony
    the Telerik team
  3. Jason
    Jason avatar
    2 posts
    Member since:
    Aug 2010

    Posted 06 Apr 2011 Link to this post

    From Mozilla's website -

    Firefox 3.6.x will be maintained with security and stability updates for a short amount of time. All users are strongly encouraged to upgrade to Firefox 4.

    Any news?
  4. Anthony
    Admin
    Anthony avatar
    19 posts

    Posted 06 Apr 2011 Link to this post

    Hello Jason,

    Our next official release will support Firefox 4. It will be out in late April or early May.

    In the meantime, an internal build (version 2010.3.1606) was released this week that is compatible. I just tested and confirmed this.

    Regards,
    Anthony
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. San
    San avatar
    24 posts
    Member since:
    Apr 2011

    Posted 27 Apr 2011 Link to this post

    Hello All,

    I'm using Telerik.WebAii.Framework.2010.3.1607.msi and found that it also doesn't support FF4.

  6. Stoich
    Admin
    Stoich avatar
    1 posts

    Posted 28 Apr 2011 Link to this post

    Hello San,
        we'll be releasing the new official R1 release in a few days. It will officially support FF4. Meanwhile we have a build which you can try - it includes FF4 capabilities. You can download it here:
    http://www.telerik.com/download/TestStudio/1615/Telerik.WebAii.Framework.2010.3.1615.msi

    Please keep in mind this is build may be less stable than an official release or even a Latest Internal Build.

    Hope to hear from you soon.

    Greetings,
    Stoich
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. San
    San avatar
    24 posts
    Member since:
    Apr 2011

    Posted 28 Apr 2011 Link to this post

    Thanks for your replying and the build.

    My problem with FF4 now was gone. It can handle the textfield type="password" and now can login successfully.

    Thank you very much for this. But I still need to wait since I could not check with Silverlight on FF (there is a ticket being tracked this one www.telerik.com/support/pits.aspx#/public/test-studio/5080 )
Back to Top
  Cast Your Vote at DevPro Connections! Cast Your Vote at  Win IT Pro Connections!