UserControl not hit Page_Load in RadWindow

2 posts, 0 answers
  1. Nuno
    Nuno avatar
    2 posts
    Member since:
    Jun 2013

    Posted 01 Aug 2013 Link to this post

    Hello, i had spend a lot of time, and for some reason the UserControl uc:MultiContactSelector
    never hits his Page_Load where its data is loaded, it always appear empty.
    I have no errors either compiling or runing
    The User Control its working properly in other pages without RadWindows and inside UpdatePanels.

    Can you give me some hint why it never hit the User Control Page_Load.


    <
    telerik:RadWindow Title="Event Info" EnableEmbeddedBaseStylesheet="false" EnableTheming="false"
            EnableEmbeddedSkins="false" ID="rwNewEvent" Modal="false" runat="server" Width="780px" Height="440px"
            VisibleStatusbar="false" Behaviors="Close">
            <ContentTemplate>            
                <asp:UpdatePanel ID="upNewEvent" runat="server" UpdateMode="Conditional">
                    <ContentTemplate>
                        <div class="form m5_rw_form">
                            <uc:FormTextbox ID="txbSubject" Label="Title" runat="server" />
                           <uc:MultiContactSelector runat="server" ID="mcsEventContacts"  />
                        </div>
     
                        <asp:Panel ID="Panel1" CssClass="m5_rw_actions" runat="server">
                            <asp:LinkButton CssClass="btnAction" ID="btnSaveEvent" Text="Save" OnClientClick="return okRadWindowNewEvent();" OnClick="btnSaveEvent_Click" runat="server" />
                            <asp:LinkButton CssClass="btnAction" ID="btnCancel" Text="Cancel" OnClientClick="return cancelRadWindowNewEvent();" runat="server" />
                        </asp:Panel>
                    </ContentTemplate>
                </asp:UpdatePanel>
            </ContentTemplate>
        </telerik:RadWindow>
  2. Nuno
    Nuno avatar
    2 posts
    Member since:
    Jun 2013

    Posted 01 Aug 2013 Link to this post

    Problem in the UserControl... This post makes no sense... Sorry
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top