We added this warning for people who prefer to name all literal arguments. It is considered by some that it improves readability and makes the code more descriptive and understandable. Lets take this code for example:
SyntaxToken token = syntaxTree.GetTouchingToken(0,
Without looking at or knowing the signature of GetTouchingToken, could you be sure what the literals stand for? Yes, the digit is predictable but the rest two literals might mean so many things. Let's look of the code when named arguments are used.
SyntaxToken token = syntaxTree.GetTouchingToken(position: 0,
cancellationToken : cancellationToken,
It looks way more understandable. Of course, this is a personal/team preference, we do not want to impose it as a better practice, hence there is a setting that disables the warning.
Do you want to have your say when we set our development plans?
Do you want to know when a feature you care about is added or when a bug fixed?
Telerik Feedback Portal
and vote to affect the priority of the items