Upstream socks proxy

5 posts, 0 answers
  1. Eugene
    Eugene avatar
    8 posts
    Member since:
    Nov 2015

    Posted 05 Nov 2015 Link to this post

    Hi!

    If I set upstream socks proxy (SSH tunnel via Putty) in Tools -> Fiddler Options -> Gateway, traffic doesn't go through it.

    If I set it via X-OverrideGateway in rules, works like a charm. Is it possible to fix it?

    Regards,

    Eugene

  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 05 Nov 2015 Link to this post

    Hello, Eugene--

    What exactly did you enter in Tools -> Fiddler Options -> Gateway?

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Eugene
    Eugene avatar
    8 posts
    Member since:
    Nov 2015

    Posted 06 Nov 2015 in reply to Eric Lawrence Link to this post

    socks=host:port
  4. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 06 Nov 2015 Link to this post

    Hi, Eugene--

    Thanks for confirming.

    At the moment, the only way to set a SOCKS gateway is via an explicit X-OverrideGateway flag on the Session. This may get cleaned up in the future, but if you find yourself adjusting this often it would be pretty simple to use FiddlerScript to add a menu command (similar to the existing User-Agent overrides) to expose it in the Fiddler UI.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Eugene
    Eugene avatar
    8 posts
    Member since:
    Nov 2015

    Posted 08 Nov 2015 in reply to Eric Lawrence Link to this post

    Thanks!
Back to Top