Upload new APK for Alpha Failed on Google Play

2 posts, 0 answers
  1. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 14 Jan 2014 Link to this post

    I get the following error:

    "Upload failed,  You uploaded an APK that was signed in debug mode. You need to sign your APK in release mode."

    I did build with the release mode. I right clicked the workspace, chose "Build Settings". From the Drop down I chose "Release", clicked "OK" button.

    When I click Run > Build, I see "Active Build Configuration: Release" at the bottom of the pop up window. I build the project, download it to my computer and upload it to Google Play Alpha tab. Then I get this error.

    Is there any other place where I need to change the value to "Release"?

    This is the first time I upload any version of my app to Google Play. I didn't create any certificate for the alpha test (don't know if I need to and if that the cause of the issue).

    In the config.xml I have: 
    <log level="DEBUG"/>,
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 15 Jan 2014 Link to this post

    Hi Idan,

    You need to use the Publish option when building for Google Play/App Store and not the Run option. The Run option will always sign your app with the debug certificate (have you noticed it does not prompt you for certificate?).

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top