Upload control not autosizing anymore

3 posts, 0 answers
  1. Andrea Rapuzzi
    Andrea Rapuzzi avatar
    28 posts
    Member since:
    Apr 2010

    Posted 30 Sep 2013 Link to this post

    Hi Telerik,
    I have a RadUpload into a Grid that has its HorizontalAlignment property set to "Stretch" (in fact it correctly expands to the whole screen width).

    Before upgrading your controls, I used to set Width="Auto" and MinWidth="0" on the RadUpload to make it stretch to the full width of the parent Grid. Now, I just passed to the 2013.2.724.1050 version, but with this code the RadUpload is not autosizing anymore (it keeps being centered, while the Grid keeps expanding for all the screen width).

    Am I doing something wrong? Do I need to change my code in some way that can allow me to obtain the same result as before the control upgrade?

    Thank you,
    Andrea
  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 30 Sep 2013 Link to this post

    Hi Andrea,

    The issue you described is caused by the default settings of the RadUpload control. At the moment the default style of the control applies the following size values:
    • MinHeight = 175
    • MinWidth = 350
    • MaxHeight = 300
    • MaxWidth = 400

    This is why in your application in order to extend the size of the component you will have to apply larger values on the MaxWidth and MaxHeight properties. Please give this a try and let us know if we can further assist you.

    Regards,
    Tina Stancheva
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
  4. Andrea Rapuzzi
    Andrea Rapuzzi avatar
    28 posts
    Member since:
    Apr 2010

    Posted 01 Oct 2013 Link to this post

    Tina,
    Thank you very much!

    I've set MaxWidth to a higher value and now it works as before!

    Andrea
Back to Top