Upgrade from Telerik 2011 to 2014

3 posts, 0 answers
  1. fatma
    fatma avatar
    10 posts
    Member since:
    Apr 2014

    Posted 08 Jan 2015 Link to this post

    I have a web application developped in VS 2010 with Telerik 2011. the used language is asp and vb.net
    I upgraded my application to the VS 2012 and Telerik 2014. I changed the Telerik references in my application with the new ones and it wokrs perfectly in my post.
    When i execute my application in my local post, all the telerik controls wokrs.
    I should deploy it in an IIs server (IIs 7). 
    But when i run my application from the IIS server, all the telerik controls doesn't works.
    Is it normal that the telerik controls works in my local post and doesn't work in the IIS server?
    Haw can i solve this problem?

  2. Pavlina
    Pavlina avatar
    6069 posts

    Posted 12 Jan 2015 Link to this post


    It is possible this problem to be related to wrong IIS configuration or javascript error. If you open the browser's console you'll probably see some javascript errors. It is very important to not have any javascript errors so the Telerik controls work properly.

    In case there is no errors, please provide some additional information (problematic code or live URL) that can help us investigate the case further.


    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  3. fatma
    fatma avatar
    10 posts
    Member since:
    Apr 2014

    Posted 29 Jan 2015 in reply to Pavlina Link to this post


    I resolved the problem, it was in the file Web.config
    I updated the version of Telerik in the web.config file.

Back to Top