Unselect on multiple selection

6 posts, 2 answers
  1. Rodenberg
    Rodenberg avatar
    18 posts
    Member since:
    Apr 2012

    Posted 14 May 2012 Link to this post

    i use the RadListBox with SelectionMode="multiple"
    I can select multiple values, but when i want to unselect a single element of the selecteditems it does not work.
    my radlistbox was bound to an observealble collection

    please help!

  2. Georgi
    Admin
    Georgi avatar
    347 posts

    Posted 16 May 2012 Link to this post

    Hello Philip,

    This issue was recently fixed. As you can in the attached video this is working with assemblies from our latest internal build. Upgrading should fix the issue.

    Regards,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Rodenberg
    Rodenberg avatar
    18 posts
    Member since:
    Apr 2012

    Posted 16 May 2012 Link to this post

    hey Georgi ,

    thanks for help. but there is an other issue ... 
    if i decalre the the radlistbox with drag and drop functionality i got each dragged item as marked!

    my scenario:
    first the target list (list with SelectionMode = "Multiple") is empty. i can drag only one by one items into it.
    the result is that each new item in this list is selected ... 

    thanks phil
  5. Answer
    Georgi
    Admin
    Georgi avatar
    347 posts

    Posted 18 May 2012 Link to this post

    Hi Philip,

    As you might now the ListBox is in beta version and we are still working on it. We have implemented this behavior by design, but obliviously it is not appropriate for your scenario. Thanks to your report we will consider changing the behavior so it will not select the dropped item. 

    Greetings,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  6. Rodenberg
    Rodenberg avatar
    18 posts
    Member since:
    Apr 2012

    Posted 22 May 2012 Link to this post

    Hey georgi,

    is there any solution until this bug is fixed?
  7. Answer
    Georgi
    Admin
    Georgi avatar
    347 posts

    Posted 28 May 2012 Link to this post

    Hello Philip,

    As you can see in the attached video the issue is fixed and the fix will be included in our next release, which is expected in the beginning of June.

    Kind regards,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top
DevCraft banner