UnderScore Problem in ID of the RadGrid

6 posts, 0 answers
  1. Velkumar
    Velkumar avatar
    85 posts
    Member since:
    Apr 2011

    Posted 18 May 2011 Link to this post

    Hello,
                 I have a RadGrid in my page. The ID of the RadGrid is "_uxSuccession". if the id has underscore in front then the grid will not work properly that is we cannot select Row in the Grid. If the Id will not contain underscore in front then the Radgrid will  work properly that is we can select the row of the rad grid. If the id contain underscore in front then no row click event will arise after clicking the row. please help me as soon as possible.

    Thanks,
    Velkumar
  2. Daniel
    Admin
    Daniel avatar
    4943 posts

    Posted 23 May 2011 Link to this post

    Hello Velkumar,

    I tried to reproduce this problem but failed. Please test the attached demo and let me know what is missing.

    Regards,
    Daniel
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Velkumar
    Velkumar avatar
    85 posts
    Member since:
    Apr 2011

    Posted 27 May 2011 Link to this post

    Hello Daniel,

                   I used this  Grid in SharePoint .I cant understand why u attached the web config file.  The above mentioned problem will arise only if  the Grid's ID has "_" (UNDERSCORE) in front that is for Example  "_GridStudent"
  5. Tsvetoslav
    Admin
    Tsvetoslav avatar
    1823 posts

    Posted 31 May 2011 Link to this post

    Hi Velkumar,

    Are you using SharePoint 2010? We no longer support SharePoint 2007 and I will be having difficulty testing your scenario?

    Regards,
    Tsvetoslav
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  6. Velkumar
    Velkumar avatar
    85 posts
    Member since:
    Apr 2011

    Posted 02 Jun 2011 Link to this post

    Hello,

             I have using  Sharepoint2007. First time , If you provide a ID for the Grid  with "_"(underscore ) in front of the ID there is no problem. If the Id of the Grid has no Under Score  ("_")  at first then suppose you rename this ID with under score ("_") in front of the this ID then the Grid will not work (Problems mentioned above will arise.)

    Thanks
    Velkumar.
  7. Tsvetoslav
    Admin
    Tsvetoslav avatar
    1823 posts

    Posted 07 Jun 2011 Link to this post

    Hello Velkumar,

    Do take into account that you should not be chaning the grid's ID dynamically, you should assign the ID initially and leave it as it was in the first place. If under SharePoint 2007 and underscore in front of the gird's ID is problematic, then just use and ID without an underscore. 

    Regards,
    Tsvetoslav
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

Back to Top
UI for ASP.NET Ajax is Ready for VS 2017