Unable to create website

5 posts, 0 answers
  1. Ben Slater
    Ben Slater avatar
    3 posts
    Member since:
    Nov 2009

    Posted 21 Jan 2010 Link to this post

    Hi,

    I recently upgraded to VS 2008 from VS 2005 (although 2005 is still installed) and installed the most recent telerik install for the templates and such, and have encountered the following error since:

    Error: this template attempted to load an untrusted component 'Telerik.Web.UI.VSX, Version=2009.03.1313.0, Culture=neutral, PublicKeyToken=0dfdc51bd06071b4'. For more information on this problem and how to enable this template please see documentation on Customizing Project Templates.

    Any idea how to fix this?
  2. Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 22 Jan 2010 Link to this post

    Hi Ben,

    I'm sorry for the trouble. We just discovered a glitch in the RadControls for ASP.NET AJAX Q3 2009 SP2 distribution regarding the RadControls VB.NET WebSite creation.

    We posted a description of the problem and a fix to the forums here:
    Untrusted component 'Telerik.Web.UI.VSX, Version-2009.03.1313.0

    I'm pasting here the details for convenience:
    1. Download the attached RadControlsForASPNETAJAXVisualBasicWebSite.zip file and copy it to the [Visual_Studio_2008_Install_Dir]\Common7\IDE\ProjectTemplates\Web\VisualBasic folder (typically C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates\Web\VisualBasic). When asked, replace the original one.
    2. Start a Visual Studio 2008 Command Prompt and run the following command:
      devenv.com /setup

    Let me know if that helps.
    Kind regards,
    Erjan Gavalji
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. loai taha
    loai taha avatar
    44 posts
    Member since:
    Apr 2007

    Posted 22 Jan 2010 Link to this post

    Ben,

    I'm facing the same problem, I also followed your insturctions, however it is never solved.

    Same error message upon creating a telerik vb.net 3.05 website.

    Note: I'm using VS 2008 and your latest ASP.NET AJAX controls (RadControls_for_ASP.NET_AJAX_2009_3_1314)

    Help is much appreciated

    Regards,
  5. Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 22 Jan 2010 Link to this post

    Hi loai taha,

    Can you please, open a Windows Explorer and navigate to the

    [Visual Studio Install Dir]\Common7\IDE\ProjectTemplatesCache\Web\VisualBasic\RadControlsForASPNETAJAXVisualBasicWebSite.zip file?

    Please, check if it contains the following entry:
    <Assembly>Telerik.Web.UI.VSX, Version=2009.03.1314.0, Culture=neutral, PublicKeyToken=0dfdc51bd06071b4</Assembly>

    If it does not contain it, that would mean that something went wrong when performing the steps in the instructions. Please, perform them again. Please, ensure that all the Visual Studio instances are closed before running the devenv.com /setup command.

    Kind regards,
    Erjan Gavalji
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. loai taha
    loai taha avatar
    44 posts
    Member since:
    Apr 2007

    Posted 22 Jan 2010 Link to this post

    Thanks Ben for your fast response. However, I downloaded an older version of ASP.NET AJAX controls (RadControls_for_ASP.NET_AJAX_2009_3_1103) and it works fine now. Hopefully your next release would solve this issue :-)

    Thanks again
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017