Unable to capture traffic in Fiddler from Windows Phone emulator

12 posts, 0 answers
  1. Srikumar
    Srikumar avatar
    3 posts
    Member since:
    Apr 2014

    Posted 09 Apr 2014 Link to this post

    Hi,
      I am trying to setup fiddler to capture traffic generated by the store apps running inside the Windows Phone emulator. While I am able to see traffic from my browser on the desktop or even remote machine, I don't see the traffic from the 8.1 emulator being logged. Things that I have tried are:

    1. Enabled remote connections in Fiddler options
    2. Set the proxy using prefs set fiddler.network.proxy.registrationhostname <machinename>
    3. Closed and restarted fiddler - And then launched emulator.
    4. Tried disabling and enabling network adapters before starting fiddler and emulator !

    Nothing worked ! Is there anything else that I can check?
  2. Srikumar
    Srikumar avatar
    3 posts
    Member since:
    Apr 2014

    Posted 09 Apr 2014 Link to this post

    FYI - I am running 8.1 windows and 8.1 emulator...
  3. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 10 Apr 2014 Link to this post

    Hello, Srikumar-- The instructions provided work for the Windows Phone 8 emulators running on any OS, but it appears that the Windows Phone 8.1 emulators have slightly changed their behavior. After upgrading to the new Version 8.1 emulators, I found that using the machinename as the value for the ProxyRegistrationHostname no longer worked: I had to use the machine's IPAddress.

    So, for instance, instead of using

        prefs set fiddler.network.proxy.registrationhostname LawrenceDev

    I instead had to use:

        prefs set fiddler.network.proxy.registrationhostname 192.168.1.123

    ...where the IP address listed is the IP of the machine running Fiddler. You can see this value in Fiddler by hovering over the Online indicator at the top-right of Fiddler. Don't forget to restart Fiddler and start your emulator AFTER Fiddler is started.

    If that doesn't work, you should try using the browser on the device to visit http://IPAddress:FiddlerPort (e.g. http://192.168.1.123:8888/) to verify that Fiddler is properly configured to allow inbound connections and the firewall isn't getting in the way.

    Please do confirm that this works for you as well so that I can update the documentation if so.

    Thanks,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  4. Srikumar
    Srikumar avatar
    3 posts
    Member since:
    Apr 2014

    Posted 11 Apr 2014 in reply to Eric Lawrence Link to this post

    Hi Eric,
      I did try the IP option as well. Any ping to the fiddler echo service ( http://<ip>:<port> ) works fine. I am able to install the fiddlerroot certificate as well.

    Connectivity from the VM seems to be fine - Because I am able to browse sites thru IE on the emulator. But I don't see any of the traffic on Fiddler.

    Any other pointers?

    Regards,
    Srikumar
  5. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 15 Apr 2014 Link to this post

    Hello, Srikumar--

    Unfortunately, no, the configuration described below (where the system is configured to use Fiddler's IP as the proxy end point) works fine for us here.

    Can you confirm that:

    1> Fiddler was started before the emulator (might want to reboot just to be positive) and
    2> When Fiddler is running, inside IE's Tools > Internet Options > Connections > LAN SETTINGS > Advanced screen, an IP address is listed?

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. Milan
    Milan avatar
    2 posts
    Member since:
    Mar 2014

    Posted 27 Jun 2014 in reply to Eric Lawrence Link to this post

    Hi,
    I have tried to follow Jeff, Eric and documentation. No success. Could you give me any other advice, please?

    Milan ;)
  7. Milan
    Milan avatar
    2 posts
    Member since:
    Mar 2014

    Posted 27 Jun 2014 in reply to Milan Link to this post

    Eric, I'd like to note that I'm in corporate network with proxy (but I've tested outside using mobile data). 
    I've tested to run both (VS and F) as admin, different port, disable Forefront TMG, disable McAfee, re-install Fiddler (with settings removed), remove all network devices in Hyper-V and also turn off and on again. ;) 
  8. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 30 Jun 2014 Link to this post

    Hi, Milan--

    You haven't given me much to go on.

    Are you using an emulator or an actual device?

    What happens when you attempt to visit http://PCIP:8888/ from the phone? Are you trying to test an application or the browser?

    If you're on a corporate network, is it using IPSEC?

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  9. Christopher
    Christopher avatar
    4 posts
    Member since:
    Jul 2014

    Posted 22 Jul 2014 in reply to Eric Lawrence Link to this post

    Hi Eric,

    I'm Running Windows 8.1 and Windows Phone 8.1 Emulator. 
    I made sure all my Fiddler Options are configured as you outline above and I've tried.
    fiddler.network.proxy.RegistrationHostName <MyIPAddress> (status bar says NotFound, so I think this is failing for me) I've tried using port 8888 and 8881 no difference for me.
    I made sure I always launch fiddler before I launch the emulator so that I ensure that fiddler establishes itself as the proxy. I've been using fiddler with Windows Phone Emulator 7 and 8 and now 8.1 but I can't get fiddler to proxy Windows Phone 8.1 at all. I've not had any issue before setting up fiddler with any of the previous version of Windows Phone Emulator, but this is the first time I've ever seen fiddler.network.proxy.RegistrationHostName <MyIPAddress> give a 'NotFound' message in the status bar, I've confirmed my IP address is correct not sure what to do next.

    Thanks,

    .Chris
  10. Christopher
    Christopher avatar
    4 posts
    Member since:
    Jul 2014

    Posted 22 Jul 2014 in reply to Christopher Link to this post

    I want to add that if I use the IE browser on the Emulator and go to http://myIPAddress:8888/ I do hit the Fiddler Echo Service page and I do see the traffic in fiddler application as well, but when debugging my WindowPhoneApp in Visual Studio 2013 Update 2 I'm not seeing any traffic.
  11. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 23 Jul 2014 Link to this post

    Hello, Christopher--

    You may want to look through the steps here:

    http://stackoverflow.com/questions/23462697/windows-phone-8-1-emulator-not-proxying-through-fiddler

    In particular, you may wish to move Fiddler to port 8889 instead of the default, due to the issue with the IPOverUSB service camping out on port 8888.

    The proper command for QuickExec is prefs set fiddler.network.proxy.RegistrationHostname whatever

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  12. Wesley Marco
    Wesley Marco avatar
    1 posts
    Member since:
    Nov 2004

    Posted 30 Sep 2015 Link to this post

    I have been seeing the same thing and have tried everything in this, MSDN Blog, and Stack Overflow.  After following those instructions I got it to work with this trick. Close out everything (AFTER following the instructions above). Delete the Virtual Machine in Hyper-V.  Start Fiddler.  Start VS.  Start the Project/Emulator.  VS recreates the Win Phone Emulator.  From that point it works.  

     

    It has stopped working again after some hours of use and closing and re-opening VS and Emulator.  Deleting the VM following these steps gets it working again.  Something with the network settings of emulator only get set correctly if Fiddler is already open when the VM is created.  So if you think it has stopped working, test with IE on the phone.  

Back to Top