Unable to apply the theme to the RadGroupbox

4 posts, 0 answers
  1. Pradeep Enugala
    Pradeep Enugala avatar
    55 posts
    Member since:
    Apr 2010

    Posted 12 Jun 2010 Link to this post

    Hi,

    I working on creating the themes to the controls using the Visual Style Builder.When i'm working with rad groupbox,i'm not able to apply the them to the control.

    For the node GropuboxContent[ check screenshot],in 'elements' dockwindow i have give all the backcolors as some lightblue color,but still it is taking the first background color [backcolor] as 'Control' color and applying it to the middle part of groupbox.but i you can observe i have given all the backcolors as blue.

    when we check it in Visual Style builder,it is showing background as user given color[blue],when it is applied in the my application then it is showing differently.

    Also applied the 'Gradient Style' as 'Solid',when this is applied the middle part is occupied with 'System Control' color not blue.

    Please check the attached screenshot and reply ASAP.

    Thank you,
    Pradeep
  2. Deyan
    Admin
    Deyan avatar
    2041 posts

    Posted 17 Jun 2010 Link to this post

    Hi Pradeep,

    Based on the screenshot you have attached, I can assume that you have not selected the correct item in the treeview on the left. If you wish to apply styles to the RadGroupBox's footer, you should select the GroupBoxFooter item and after that apply styles to its elements.

    Please refer to the attached screenshot for further details.

    Kind regards,
    Deyan
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Pradeep Enugala
    Pradeep Enugala avatar
    55 posts
    Member since:
    Apr 2010

    Posted 21 Jun 2010 Link to this post

    hi Deyan,

    Thanks for Ur reply.
     The problem for my issue is solved by changing the back color of the controls UI Elements properties.I have applied the theme for the group box but still have to change the properties[UI Elements] of the group box and it's working.

    Thanks
    Pradeep
  5. Deyan
    Admin
    Deyan avatar
    2041 posts

    Posted 23 Jun 2010 Link to this post

    Hi Pradeep,

    Depending on your requirements, you can either use the Edit UI Elements dialog to change the color or set it by theme. By setting the colors from the Edit UI Elements dialog you will override the theme settings and thus, if you plan to change themes in runtime, you will loose the theming of the RadGroupBox's elements which have been modified by the Edit UI Elements dialog.

    I hope this helps.

    Best wishes,
    Deyan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top