TypeScript 0.9.0 support

4 posts, 0 answers
  1. Halstein Tonheim
    Halstein Tonheim avatar
    1 posts
    Member since:
    Apr 2010

    Posted 19 Jun 2013 Link to this post

    TypeScript 0.9.0 was just released (http://blogs.msdn.com/b/typescript/archive/2013/06/18/announcing-typescript-0-9.aspx), but the kendo.all.d.ts typescript definitions aren't compatible with it. The TypeScript 0.9.0 compiler throws 20 errors about "'declare' modifier required for top level element.".

    Any ETA on a typescript type definition file that supports TypeScript 0.9.0?

  2. Atanas Korchev
    Admin
    Atanas Korchev avatar
    8221 posts
    Member since:
    Sep 2012

    Posted 19 Jun 2013 Link to this post

    Hi,

     Indeed TypeScript 0.9 isn't backwards compatible and as a result the Kendo UI TypeScript definitions are broken. Fortunately it was an easy fix. Find the updated definitions attached.

    Regards,
    Atanas Korchev
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!

  3. Donald
    Donald avatar
    23 posts
    Member since:
    Nov 2013

    Posted 10 Apr in reply to Atanas Korchev Link to this post

    This seems to be broken again, in the latest version of Kendo UI

  4. Atanas Korchev
    Admin
    Atanas Korchev avatar
    8221 posts
    Member since:
    Sep 2012

    Posted 14 Apr Link to this post

    Hello,

    This is a known issue which we have addressed in the latest internal build.

    Regards,
    Atanas Korchev
    Telerik

     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     

Back to Top