Trouble with Checkboxes

4 posts, 0 answers
  1. David
    David avatar
    2 posts
    Member since:
    Sep 2012

    Posted 13 Sep 2012 Link to this post

    Hi,

    Both Template and CheckboxTemplate do not seem to affect my nodes that have been created through BindTo.  Special characters in the templates are also resulting in their escaped source code representations such as "\u0027".  Can you guys please provide some advice and perhaps an example of a databound TreeView created through the Fluent API that uses checkboxes?  Thanks. 
  2. Bruno
    Bruno avatar
    4 posts
    Member since:
    Sep 2012

    Posted 17 Sep 2012 Link to this post

    I´m having the same problem, seems that if you are not a MVP user, your question is ignored!

    http://www.kendoui.com/forums/ui/treeview/help-with-checkboxtemplate.aspx

    Can someone answer?!
  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Gajanan
    Gajanan avatar
    1 posts
    Member since:
    Feb 2013

    Posted 28 Feb 2013 Link to this post

    I am facing same problem . Can anybody suggest solution on this.
  5. Alex Gyoshev
    Admin
    Alex Gyoshev avatar
    2500 posts

    Posted 05 Mar 2013 Link to this post

    Both the Template and CheckboxTemplate fields define a client-side template, and BindTo renders the items from the server (thus, cannot apply the template). If you use the DataSource binding and set its Data, the data will be rendered on the client along with the template. We will be modifying the BindTo method to do this automatically, but until we do, provide the data directly to the DataSource.
     

    Regards,
    Alex Gyoshev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top
UI for ASP.NET MVC is VS 2017 Ready