Trouble testing on iPhone 6/IOS8

12 posts, 2 answers
  1. Brad Sumner
    Brad Sumner avatar
    28 posts
    Member since:
    Dec 2009

    Posted 20 Sep 2014 Link to this post

    I'm trying to test the cuteness app on an iPhone 6 using the Red Laser scanner to load the app with the Companion app but scanning the QR code launches the Companion app with a blank black screen.  I've tried removing and re-installing the companion app but I'm still having the same result.
  2. Answer
    Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 22 Sep 2014 in reply to Brad Sumner Link to this post

    Hey Brad - this is expected - the NativeScript companion app has not been updated to have iOS8 support.

    with 0.3 release (which is coming next week) we have the runtime running under iOS8 and we will update the companion app so that you can test on your need device.

    If you want to test the bits earlier - please let me know - I think I can setup a private repo and using the CLI you should be able to test it.

    Greetings,
    Valio
  3. Brad Sumner
    Brad Sumner avatar
    28 posts
    Member since:
    Dec 2009

    Posted 22 Sep 2014 in reply to Valio Link to this post

    Thanks Valio!

    I can wait and will keep an eye out for the 0.3 release.

    Brad
  4. Panayot
    Panayot avatar
    1 posts
    Member since:
    Nov 2013

    Posted 30 Oct 2014 in reply to Brad Sumner Link to this post

    Hey Brad,

    did you had a chance to test the new bits on your new device? You can follow these instructions to build an app with the 0.3 version. More info is coming next week as we setup the integration with AppBuilder, but right now it is possible to use the CLI tools to create an app.

    Greetings,
    Valio
  5. Brad Sumner
    Brad Sumner avatar
    28 posts
    Member since:
    Dec 2009

    Posted 30 Oct 2014 in reply to Panayot Link to this post

    I like the option provided by the instructions but I don't have a Mac yet :-(  I'll keep an eye out for AppBuilder news next week.

    Thanks,
    Brad
  6. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 01 Nov 2014 in reply to Brad Sumner Link to this post

    AppBuilder update is live now.  You can test.
  7. Brad Sumner
    Brad Sumner avatar
    28 posts
    Member since:
    Dec 2009

    Posted 11 Nov 2014 in reply to Valio Link to this post

    Valio,

    I tried setting up the new project from the post http://www.telerik.com/forums/nativescript-getting-started-samples and running it on my phone but I'm still unable to get it to work.  I reinstalled the companion app and scanned the build qr code and the native script companion app opens with a black screen and a green dash in the top right that looks like the battery bar.

    I'm running IOS 8.1 on an iPhone 6.  Should we be able to run the project at this point on the device?

    Thanks,
    Brad
  8. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 11 Nov 2014 in reply to Brad Sumner Link to this post

    Hi Brad, Unfortunately no :( Our companion app got rejected last time from AppStore and we are currently fixing the issues. They are not related to NativeScript, but it will take some time for the app to get published on the App Store with the latest NativeScript runtime enabled.


    That said you can still deploy on your device, but not by using the companion app. With the latest update of AppBuilder we enabled cloud builds for the applications, so you can instruct AppBuilder to use your iOS provisioning profiles and create an IPA file which you can then ad-hoc deploy to your devices. Here is how to set your provision profile - http://docs.telerik.com/platform/appbuilder/code-signing-your-app/configuring-code-signing-for-ios-apps/create-ad-hoc-provisioning-profile

    Here is how to create an IPA file - http://docs.telerik.com/platform/appbuilder/nativescript/publish


    We have a release 0.4 scheduled for next week and hopefully by then we will have the companion app updated and you will not need to do this, but for the moment this is the only option for you.

    Please let me know if you have any questions!

    Best,
    Valio
  9. Answer
    Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 20 Nov 2014 Link to this post

    Hey Brad,

    this issue is fixed now with our 0.4 release. You can give it a try, but please update the companion app from the AppStore before that :)

    Greetings,
    Valio

  10. Brad Sumner
    Brad Sumner avatar
    28 posts
    Member since:
    Dec 2009

    Posted 20 Nov 2014 in reply to Valio Link to this post

    The was the first thing I did but I'll go ahead and remove both apps and reinstall both.  Is the AppBuilder app used with Nativescript apps or just the NativeScript app?

    Right now I'm showing AppBuilder 2014.10.21.16.13.  I can't tell on the NativeScript app - it just closes as soon as I open it so it may just be a bad install.

    I'll post back with the results.
  11. Brad Sumner
    Brad Sumner avatar
    28 posts
    Member since:
    Dec 2009

    Posted 20 Nov 2014 in reply to Valio Link to this post

    I reinstalled just the NativeScript app and clicked the icon and the cuteness app loaded immediately. 

    The scrolling and navigation feels very smooth.  I like the Xaml - like design layout though I may have a bias to Xaml but I'm open to other ideas.

    Thanks again!

    Brad
  12. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 20 Nov 2014 in reply to Brad Sumner Link to this post

    Thanks Brad, this is so great to hear!

    As you noticed - you don't need the PhoneGap companion app. NativeScript app is all you need to work with NativeScript.
Back to Top