Toolkit configuration will not run under windows 7

4 posts, 1 answers
  1. King
    King avatar
    3 posts
    Member since:
    Aug 2011

    Posted 15 Aug 2011 Link to this post

    Hi,

    Under Windows 7, if the user is an admin, you do not need to run VS 2008/2010 as an admin. Also, the OS will not let you launch VS via the right click admin option.

    I'm able to install other 3rd parties toolkits on the toolkit window box.

    With that said, the telerik toolkit configuration fail to install because it can not access the Registry. It says run as an admin... but Window 7 64-bit OS will not launch the VS 2008/2010 software through the admin run option.

    Do anybody know a workaground?

    PS: If I have a path to the toolkit dll... then I can install it manually via the toolkit box command menu.
     
    King
  2. Answer
    Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 16 Aug 2011 Link to this post

    Hi King,

    That's interesting, basically, even if the current user is part of the local administrators group, if the User Account Control is turned on, the processes are run with limited privileges. That's the reason the ToolboxConfigurator (part of the VSExtensions) asks for administrative permissions. The problem you are experiencing is a strange one though, for the ToolboxConfigurator is operating in the local user registry, which the IDE has access to. On the other hand, a right-click on the Visual Studio icon and a click to the "Run As Administrator" option should not cause errors, it should launch the process... Can you check with the administrators in your organization for assistance with the machine configuration?

    Anyways, the assembly, containing RadControls for ASP.NET AJAX is Telerik.Web.UI. You could browse it to manually populate the Toolbox. If you used the installer, you can find it under the RadControlsInstallDir (typically C:\Program Files (x86)\Telerik\RadControls for ASP.NET AJAX Q2 2011\BIN40). On the other hand, if you had used the VSExtensions to download the latest version, you could find the assembly under the %appdata%\Telerik\Updates folder.

    Let me know if that helps.

    Kind regards,
    Erjan Gavalji
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. King
    King avatar
    3 posts
    Member since:
    Aug 2011

    Posted 17 Aug 2011 Link to this post

    Hi,

    Thanks, the admin problem still exist... but I Reset the VS settings to the startup values and the telerik toolkit mysteriously appeared.

    King
  5. Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 22 Aug 2011 Link to this post

    Hi King,

    Sorry for not being able to sort the "run VS as Admin" problem out. I did some research on the matter, but could not find any related information. As a side note, I believe Microsoft Support might have some more information about that and you might consider asking them for further information. I'll appreciate if you can post the results here too.

    Best,
    Erjan Gavalji
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

Back to Top