Toolbar in Windows7 theme

4 posts, 1 answers
  1. andrea bellagamba
    andrea  bellagamba avatar
    43 posts
    Member since:
    Jul 2009

    Posted 25 Mar 2010 Link to this post

    When the Windows7 theme is applied, the tool bar button seem to have a problems.
    The first button on the toolbar works fine, but all the other do not change appearance on mouseover or mouseclick.

    I have prepared a test Project but I can't upload it.

    Thanks
  2. Answer
    Bobi
    Admin
    Bobi avatar
    513 posts

    Posted 25 Mar 2010 Link to this post

    Hello andrea bellagamba,

    It was not clear enough what version of Silverlight are you using.
    I suppose that you mean Silverlight 4RC. If so then we are aware of this issue and we released an additional version of our controls made especially for SL4 RC. You can  download it from here:
    http://www.telerik.com/account/free-trials/download-trial-file.aspx?fileid=10279&dispkey=True

    Unfortunately for now if you use a custom theme, you will have to replace StaticResources with their values (only in VisualStates).
    Please find attached a sample project.
    I hope that this will help you.
    Please let us know if you have any other questions or need some more help.

    Greetings,
    Bobi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft banner
  4. Ulrich Fiege
    Ulrich  Fiege avatar
    62 posts
    Member since:
    Sep 2005

    Posted 14 Jun 2010 Link to this post

    Hello, when i use the toolbar with Windows7 theme (current and latest version SL3 AND SL4) it
    appers only red on screen. I replaced the toolbar.xml with an old one in the theme project. After that it
    works correctly. Please can you check this issue.
    Thanks ...

     
  5. Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 18 Jun 2010 Link to this post

    Hello Ulrich,

    Please, accept our apologies for the late reply.

    Unfortunately, we were not able to reproduce the issue you've encountered. Please find attached a sample file. You can compare it with your project. If you still have any problems you can send us the your project.

    P.S: One a side we just released a very cool new tool for Silverlight! If you want to reduce the size of your Silverlight application, you should check our latest Silverlight tool online - Assembly Minifier (http://blogs.telerik.com/blogs/posts/10-06-10/telerik_assembly_minifier.aspx).

    Kind regards,
    Dimitrina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top