Too large ScheduleView

5 posts, 1 answers
  1. Vonziz
    Vonziz avatar
    17 posts
    Member since:
    Sep 2011

    Posted 25 Jan 2012 Link to this post

    Hi everybody,

    I want to know how to autosize my RadScheduleView's width to its component area without horizontal scrollbar.
    This thing is automatically done with height but not with width.

    Very strange... :-)

    Thanks!
  2. Ivo
    Admin
    Ivo avatar
    390 posts

    Posted 30 Jan 2012 Link to this post

    Hi,

    I would suggest you use  MinTimeRulerExtent and MaxTimeRulerExtent properties of the RadScheduleView. Setting a small value to the MaxTimeRulerExtent and a large one to the MaxTimeRulerExtent will do the trick for you.

    All the best,
    Ivo
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Vonziz
    Vonziz avatar
    17 posts
    Member since:
    Sep 2011

    Posted 30 Jan 2012 Link to this post

    Hi Ivo!

    With this code :

    <scheduleView:RadScheduleView
                                               x:Name="scheduleView"
                                               Height="600"
                                               Width="1075"     
                                               GroupHeaderContentTemplateSelector="{StaticResource GroupHeaderContentTemplateSelector}"
                                               SpecialSlotStyleSelector="{StaticResource SpecialSlotStyleSelector}"
                                               SpecialSlotsSource="{Binding SpecialSlots}"
                                               AppointmentsSource="{Binding AppointmentListe}"
                                               ResourceTypesSource="{Binding SalleListe}"
                                               ShowDialog="RadScheduleView_ShowDialog"
                                               VisibleRangeChangedCommand="{Binding SchedulerRangeChanged}"
                                               VisibleRangeChangedCommandParameter="{Binding VisibleRange, RelativeSource={RelativeSource Self}}">
                                   <telerik:RadScheduleView.GroupDescriptionsSource>
                                       <telerik:GroupDescriptionCollection>
                                           <telerik:ResourceGroupDescription ResourceType="Rooms" />
                                       </telerik:GroupDescriptionCollection>
                                   </telerik:RadScheduleView.GroupDescriptionsSource>
                                   <scheduleView:RadScheduleView.ViewDefinitions>
                                       <scheduleView:DayViewDefinition
                                           x:Name="dayView"
                                           Orientation="Horizontal"
                                           TimerulerMajorTickStringFormat="{}{0:%H}:{0:mm} "
                                           GroupHeaderDateStringFormat=""
                                           DayStartTime="{Binding DayStartTime}"
                                           DayEndTime="{Binding DayEndTime}"
                                           MinTimeRulerExtent="1000"
                                           MaxTimeRulerExtent = "10"
                                           MinorTickLength="{Binding TickLength}"
                                           MajorTickLength="{Binding TickLength}"  />

    My scheduler is not perfectly autosized as you can see on the attached print screen.
    Have you got an another trick?
  5. Answer
    Ivo
    Admin
    Ivo avatar
    390 posts

    Posted 30 Jan 2012 Link to this post

    Hi,

    Try setting 10 to MinTimeRulerExtent and 10000 to MaxTimeRulerExtent.

    Kind regards,
    Ivo
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  6. Vonziz
    Vonziz avatar
    17 posts
    Member since:
    Sep 2011

    Posted 30 Jan 2012 Link to this post

    Works perfectly!
    Thanks a lot. :-)
Back to Top
DevCraft banner