Toggle Button

4 posts, 0 answers
  1. Phil
    Phil avatar
    2 posts
    Member since:
    Feb 2015

    Posted 06 Apr 2015 Link to this post

    Hi

     I don't have any joy with toggle buttons. Even the demos

    http://demos.telerik.com/aspnet-ajax/button/examples/overview/defaultvb.aspx?show-source=true

    dont work when you select "toggle". They seem to display as text - no button, and no ability to skin them

     am I doing something wrong?

    best regards

    Phil

  2. Danail Vasilev
    Admin
    Danail Vasilev avatar
    1490 posts

    Posted 07 Apr 2015 Link to this post

    Hello Phil,

    Could you please elaborate more about the issue?

    Generally the RadButton control supports different functionality and appearance. For example you can have a standard, skinned or linked button configured either as normal buttons or configured to have a radio/checkbox functionality. You can also have a pure checkbox/radio button appearance and functionality.

    I can suggest that you start with our online demos and documentation to see how to configure the desired appearance and configuration:
       - Image Button -  http://demos.telerik.com/aspnet-ajax/button/examples/imagebutton/defaultcs.aspx
       - Toggle Button - http://demos.telerik.com/aspnet-ajax/button/examples/togglebutton/defaultcs.aspx
       - Radios and Checkboxes - http://demos.telerik.com/aspnet-ajax/button/examples/radiosandcheckboxes/defaultcs.aspx


    If you have a particular issue please elaborate more - what is the actual and the expected behavior of the button, so that I can provide a reliable solution.

    Regards,
    Danail Vasilev
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Phil
    Phil avatar
    2 posts
    Member since:
    Feb 2015

    Posted 08 Apr 2015 in reply to Danail Vasilev Link to this post

    on your demo page

    http://demos.telerik.com/aspnet-ajax/button/examples/overview/defaultvb.aspx?show-source=true

    standard button, link button renders fine

    toggle button shows just text , no button

    tested on many computers, many browsers

  5. Danail Vasilev
    Admin
    Danail Vasilev avatar
    1490 posts

    Posted 08 Apr 2015 Link to this post

    Hi Phil,

    After setting the button type to toggle did you change the toggle type to checkbox/radio or you have left it to none? Because this behavior is expected for none toggle type. See an example here - http://screencast.com/t/GcuLtqta

    Regards,
    Danail Vasilev
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
Back to Top