TileView is not working properly when app has several windows

2 posts, 1 answers
  1. Ivan
    Ivan avatar
    2 posts
    Member since:
    Jul 2010

    Posted 15 Mar 2011 Link to this post

    Hello! Recently found bug with RadTileView. In my project I have several modeless windows that have RadTileView inside them. Inside my main window TileView is working good, but inside all other windows item dragging inside RadTileView is buggy, when I start drag - there is no animation there and RadTileViewItems are not repositioned during drag operation. Only when I release mouse button I can see a result. And also if I spend some time dragging items in that TileViews, app often crashes with stack overflow in Telerik.Windows.Controls.Navigation.dll. Finally I've found the solution for that - always set Application.Current.MainWindow to window that is active at the moment. But this is not very convenient. Can you help me to solve that issue?

    Best regards,
    Ivan Petroff
  2. Answer
    Zarko
    Admin
    Zarko avatar
    755 posts

    Posted 16 Mar 2011 Link to this post

    Hello Ivan,

    Thank you for the bug report. 
    This issue was fixed for the Q1 Beta (released a couple of weeks ago) and the fix for it will also be present in the upcoming Q1 Release (expect it until the end of the week).

    Regards,
    Zarko
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
  3. UI for WPF is Visual Studio 2017 Ready
Back to Top