Theme in resources

3 posts, 0 answers
  1. BrzozAle
    BrzozAle avatar
    9 posts
    Member since:
    May 2007

    Posted 30 Jul 2007 Link to this post

    Hi
    I created xml theme file for RadPanel in VisualStyleBuilder.
    At start I put ThemeManager on my form and added to Loaded Themes my theme.I set StorageType as "File" and showed FilePath in ThemeLocation.
    It worked,but now I want  add this xml file to resources.And I have a problem,because in design form I have Visual Style,I created,but in run time it doesn`t work (view like after "reset").
    I`ve changed StorageType on "Resource" and I`ve tried write many combinations of "ThemeLocation",but it doesn`t work every time.
    I have solution with many libraries, where I use this schema,so What I should to do?
    For example : Form1 which is in Library1.dll and this Form has my Panel,and I have main project "Project",where after buttonClick I show this form with this panel.
    Thanks for help

    Aleksander


  2. Mike
    Admin
    Mike avatar
    640 posts

    Posted 30 Jul 2007 Link to this post

    Hello Alexander,

    Please review the following thread which contains information about loading themes from resource and a suggestion on how to quickly validate your resources names.
    http://www.telerik.com/community/forums/thread/b311D-gdcka.aspx
    Also please note that in the current version of RadControls, when loading theme from a resource, the theme would not be loaded instantly in the VS designer, but it should be ok when you run the application. I hope this would help.

    Kind regards,
    Mike
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for WinForms is Visual Studio 2017 Ready
  4. BrzozAle
    BrzozAle avatar
    9 posts
    Member since:
    May 2007

    Posted 31 Jul 2007 Link to this post

    Thank You for help
    It works.

    Aleksander

Back to Top