Theme does not apply properly to RadGrid

4 posts, 0 answers
  1. anca
    anca avatar
    6 posts
    Member since:
    Nov 2007

    Posted 03 May 2010 Link to this post

    Hello,

    i have a tabstrip, each tab containing a grid. In the first tab the grid looks ok with the skin i've created, but the second tab doesn't display properly the same grid. I've attached an image showing this issue. Is there any solution for this problem?
    Can i style the expande/collapse buttons?

    Thanks a lot
  2. Victor
    Admin
    Victor avatar
    1351 posts

    Posted 03 May 2010 Link to this post

    Hi anca,

    Thank you for the question.

    In the left part of the screenshot of your grid looks ok because you have created styles for the group rows.

    In the right part you are displaying a hierarchy. You need to create styles for the hierarchy view as well. You can switch to hierarchy view via the context menu that opens when you right click the RadGridView tree node in Visual Style Builder.

    A bit off topic, please ask the person who has purchased our controls in your company to add you as a License Developer to the purchase. This will give you full access to the products your company has purchased, to our downloads section, and to our support ticketing system. Additionally, all your questions will be reviewed according to the license you have. More information on License Developers you can find here: www.telerik.com/account/faqs.aspx.

     
    Sincerely yours,
    Victor
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. UI for WinForms is Visual Studio 2017 Ready
  4. anca
    anca avatar
    6 posts
    Member since:
    Nov 2007

    Posted 04 May 2010 Link to this post

    Hello Victor,

    thank you for your answer! I thought that might be the problem but i can't seem to find the expander in the hierarchy view in the Style Builder and i don't understand either what are the "table" elements displayed on top of the table and the black border that comes around it. None of this can be edited in the Style Builder. I also tryed to put images for expanders but the images are not properly displayed.

    Thank you
  5. Victor
    Admin
    Victor avatar
    1351 posts

    Posted 05 May 2010 Link to this post

    Hello anca,

    We would appreciate it if you take care of our second recommendation about your license. I am afraid that failure to take care of this will result in no responses fromour support system in the future. Thank you for the understanding. 

    In order to edit different items you need to switch between the control views since not all editable elements are available in a single view. In the Q1 2010 SP1 release the expander cell is located in the hierarchy view, please see the attached screenshot, the selected element in the tree on the left is the expander cell.

    Regards,
    Victor
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top