Test execution fails to trigger recorded action

5 posts, 0 answers
  1. Uroš
    Uroš avatar
    37 posts
    Member since:
    Dec 2013

    Posted 03 Nov 2015 Link to this post

    I have one weird situation with a test execution. Element verification and annotation show the right element, but the button (Sign in) is not selected during the execution. Test project included in att.
  2. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 06 Nov 2015 Link to this post

    Hello,

    Thanks for sending the test case in question!

    This is weird because I execute RunToHere in the Login test until the Click step, then I manually click on the button and again nothing happens. I see from the page source there is JavaScript function supposed to be attached on click, but I don't see the JavaScript anywhere. Could it be this page is not fully functional yet?

    Regards,
    Konstantin Petkov
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Uroš
    Uroš avatar
    37 posts
    Member since:
    Dec 2013

    Posted 06 Nov 2015 in reply to Konstantin Petkov Link to this post

    The page is functioning, because if you open a browser manually, go to the web site http://portaldoorcloud.gear.host/ and enter credentials, you can enter the application. If you try to do the same with the browser started by TestStudio, it does not work...
  4. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 06 Nov 2015 Link to this post

    Hi,

    Indeed, it seems the submit button needs updates from the user/pass input boxes. Checking the SimulateRealTyping property for those enter text steps makes the click button enter the next page.

    Regards,
    Konstantin Petkov
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  5. Uroš
    Uroš avatar
    37 posts
    Member since:
    Dec 2013

    Posted 09 Nov 2015 in reply to Konstantin Petkov Link to this post

    Yes, that has solved the problem.
Back to Top