Test Automation: ComboBox items disappear after click

2 posts, 0 answers
  1. Waldemar
    Waldemar avatar
    1 posts
    Member since:
    Sep 2013

    Posted 23 Sep 2013 Link to this post

    Hi all,
    i am evaluating test automation on our Silverlight Web Application, which contains telerik controls.
    The recognition of most controls is great,but we have "usability problems" with Telerik combo boxes. 
    After opening the page, all the combo boxes have items, but after click on combo box, disappear all elements of the combo box. Open combo box contains no more items.
    Its possible to reproduce this behavior on the demo page with standard microsoft tool ui spy:
    1. Open the page: http://demos.telerik.com/silverlight/#ComboBox/FirstLook (3 ComboBoxes in Search Criteria region -> Technology / Category / Order by)
    2. Find the combo box in UI spy, expand the combobox item in UISpy -> e.g. "technology" cb has 4 items
    3. Click on ComboBox "Technology" (demo page)
    4. Refresh CB in UISpy -> technology cb has no items!

    Do you have any idea?

    Thanks in advance,
    Waldemar
  2. George
    Admin
    George avatar
    1332 posts

    Posted 25 Sep 2013 Link to this post

    Hi Waldemar,

    We are aware of this problem in RadComboBox control and it's already logged in our PITS here - http://www.telerik.com/support/pits.aspx#/details/Issue=14897 You could track its change and vote for it as well. The issue is not scheduled yet, but we will definitely will look into it in our further development.

    Hope this helps.

    Regards,
    George
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
Back to Top