telerik website - follow up

22 posts, 0 answers
  1. Natalie Farah
    Natalie Farah avatar
    1 posts
    Member since:
    Mar 2006

    Posted 30 Jun 2006 Link to this post

    Hello,

    My name is Natalie Farah and I am the manager of telerik website team. I would like to address this post to all of you who have experienced problems with the speed of our website.

    It's been a while since the last discussion on the topic has been closed. Now I am glad to let you know that during the past few weeks the telerik webteam has devotedly worked on improving website performance. We made a number of optimizations and the results are in front us. I hope you have also noticed the change.

    I will be glad to get some feedback since the your opinion will be of great value for us and for any future improvements we decide to make. Whether you have noticed a change or not, please post a few words as a reply to this thread to share your impressions.

    Best regards,

    Natalie
  2. Mostafa Anoosheh
    Mostafa Anoosheh avatar
    462 posts
    Member since:
    Nov 2005

    Posted 01 Jul 2006 Link to this post

    Hello Natalie,
    Thanks for optimizing the site.
    I found a simple bug in your development.
    When new post send to the forum on my topics i must see an unread icon before it on My CLient.net and forums but no icon displayed.

    Excuse me english isn't my native language.
    Best regards
    Mostafa Anoosheh
  3. Martin de Ruiter
    Martin de Ruiter avatar
    99 posts
    Member since:
    Jun 2005

    Posted 01 Jul 2006 Link to this post

    Hello Natalie,

    I must say the speed of the website has definately improved, at this moment I experience no problem at all with any part of the website (while earlier for example the forum was sometimes slow). Great work!

    Kind regards,

    Martin de Ruiter
  4. Mark Chipman
    Mark Chipman avatar
    219 posts
    Member since:
    Nov 2004

    Posted 02 Jul 2006 Link to this post

    Hi Natalie:


    The site is working nice now.  I would still like to see these improvements though in short order if you will address them:

    • Easy method to find ALL postings that have 1.) code examples 2.) links to other content/sites/examples... I can't tell you how many times I remember reading about a certain topic and remembering that it contained sample code OR a link to another site...but been unable to find it again when I needed to.   I hope you understand my reasoning for asking for this.
    • "Auto- save" a draft version when creating a post (this could be a timer based event every 30 seconds or so)... Why?  Numerous times I've spent alot of time creating a post then when I hit submit it has gone into never never land... and when I hit "back" the content is gone.  This hasn't happened in a while, but it definitely makes me nervous every time I hit submit (that is..."Reply")!  Also this would be helpful if someone accidently shoots off to another URL accidentally prior to posting their message.
    • Have a dedicated "chat" tool so that we can all talk to one another in realtime!  I personally dislike waiting for someone to respond to a posting sometimes when it would be much better to have a live exchange with others.  I foresee a sort of chatrooms type of setup (dedicated to general and specific topics like individual controls support).  (Hmmm, maybe give MVPs moderator privileges!).

    Thanks,  I hope this helps you.

    -Mark Chipman

  5. Natalie Farah
    Admin
    Natalie Farah avatar
    170 posts

    Posted 03 Jul 2006 Link to this post

    Hi everyone,

    Thank you all for taking some time to reply to this posting and for your positive comments concerning the website improvements.

    Now, up to the points mentioned in your posts.

    Mostafa, you are the right that the "new post" icon is never displayed in your list of forum threads in the client.net - we are going to fix it. Thank you for reporting this issue.

    Mark, here are my comments on your three suggestions:
    • Finding posts with code examples and links - if I understood it correctly you would like to have some functionality to get a list of all these threads. If that is so, I am not sure how helpful will be - the number of such threads is too large to be useful without applying other filters. The easiest way to find a thread you have looked at is to subscribe for it and then when you need it again simply go to "My forum threads". Also, within a week we are going to launch a new search on our website, which will make the finding of any information much easier than it is now.
    • Auto-save - during the past month we got this suggestion a few times. It is included in the plans of our web team and we are going to implement it.
    • Chat tool - I am sure you understand this one requires the most work and will take us some time to implement. That why we need to think it over to make sure it will be worth the efforts. For the time being, I am going to discuss your suggestion with our support team and will let you know if we decide to implement it.
    Regards,
    Natalie Farah
    the telerik team
  6. Sean Marchiafava
    Sean Marchiafava avatar
    12 posts
    Member since:
    Apr 2006

    Posted 14 Sep 2006 Link to this post

    Natalie,

    Site is performing much better. The search functionality has recently changed where when I am searching within a particular control forum I get results from other forums. Its almost like the filter is not in effect.

    I love the look of the site. What is the chance you could share the css that creates the tabed content borders on all the demo sites, where it says Example, Quickstart, Upgrade etc.  That is really nice. I tried to find it in the controlexamples project but I'm just not smart enough to track it down.

    Thanks,
    Sean
  7. Natalie Farah
    Admin
    Natalie Farah avatar
    170 posts

    Posted 15 Sep 2006 Link to this post

    Hi Mark,

    I am glad to hear people do notice the improvement. Concerning the changed forums search - it is not that the filter is not working. Approximately two weeks ago we launched a completely new search which does not provide the option for a search in a specific forum only. For more information on the reasons for this change you can take a look at this forum thread. As mentioned in the thread, we are going to bring back the old search and the possibility to select particular forum.

    As to your question about the css, you can find the skins you are looking by following this link.

    Regards,
    Natalie Farah
    the telerik team
  8. Mostafa Anoosheh
    Mostafa Anoosheh avatar
    462 posts
    Member since:
    Nov 2005

    Posted 16 Sep 2006 Link to this post

    Hello all,
    I find some good improvments in site, but i want vote Mark suggestions.
    And i want again suggest you to use HTTP compression at minimum for static objects such as JS, CSS, XML .

    Excuse me English isn't my native language
    Best regards
    Mostafa
  9. Steve Newbery
    Steve Newbery avatar
    103 posts
    Member since:
    Apr 2005

    Posted 02 Oct 2006 Link to this post

    Hi Natalie,

    Just saw the new menus on the site, and they look fine.

    But when I move the cursor over them the hourglass cursor flashes a lot. I guess this is the well-known IE6 bug? Is there no easy solution for it within IE6?

    Regards, Steve
  10. Natalie Farah
    Admin
    Natalie Farah avatar
    170 posts

    Posted 02 Oct 2006 Link to this post

    Hello Steve,

    In most cases, the reason for the flicker/reloading is that when the browser cache is disabled (check for new versions > every visit to the page), the browser requests the background image every time, rather than only once (on page load). The request to the server and the response takes some time, hence the flicker effect. If you use a skin that has no images inside (CSS only), you will see that this effect disappears.

    I suggest you check your IE settings at Tools -> Internet Options -> Temporary Internet files -> Settings; it has to be set to Automatically.

    Note that this is a browser related problem (under Mozilla everything is ok) as it does not cache the images, i.e. it reloads them every time. Unfortunately, we cannot force it to cache the images. I hope that this information in the following blog posts will help you:
    http://weblogs.asp.net/scottgu/archive/2006/05/29/Eliminating-CSS-Image-Flicker-with-IE6.aspx
    http://www.aspnetresources.com/blog/cache_control_extensions.aspx

    In addition, please note that the internal VS2005 development server (aka Cassini) does not use cache and if you run your application through it you will always have the flicker on your pages.

    Kind regards,
    Natalie Farah
    the telerik team
  11. Steve Newbery
    Steve Newbery avatar
    103 posts
    Member since:
    Apr 2005

    Posted 02 Oct 2006 Link to this post

    Natalie,

    Thanks for the reply. Yes I read Scott's blog before, when I was trying to eliminate the flicker with some buttons etc on my site. But nothing worked, and I did give up.

    For the new menus on the Telerik site, changing the cache setting has no effect - even when I set it to "never" I still get the flicker. Apparently it's because IE6 cannot cache background images.

    One solution using "trifecta" buttons is here - maybe this strategy could be used for Telerik's menus? I'm certainly going to experiment with it myself - just for rollover buttons though.

    Best regards, Steve
  12. Natalie Farah
    Admin
    Natalie Farah avatar
    170 posts

    Posted 02 Oct 2006 Link to this post

    Hi Steve,

    Thanks for providing this link. We'll certainly take a look at it and try to fix the problem on our website.

    Greetings,
    Natalie Farah
    the telerik team
  13. Todd Anglin
    Todd Anglin avatar
    2040 posts
    Member since:
    Aug 2005

    Posted 03 Oct 2006 Link to this post

    Natalie,

    I observed another issue with the new menus on telerik's site. If you expand the Products > ASP.NET > What's Included menu on the telerik homepage you'll notice that the "featured customers" flash element overlaps the menu.

    I know menu is supposed cover flash elements on a page, so I'm not sure why this menu seems to be failing. This is either a menu issue or a problem unique to the website update. Either way, just FYI...

    Thanks~
  14. Natalie Farah
    Admin
    Natalie Farah avatar
    170 posts

    Posted 04 Oct 2006 Link to this post

    Hi Todd,

    This is a Firefox issue only. It's not actually a problem but an incorrectly set property. Thanks for reporting this glitch in our website update. We'll make sure to have it fixed ASAP.

    Kind regards,
    Natalie Farah
    the telerik team
  15. Todd Anglin
    Todd Anglin avatar
    2040 posts
    Member since:
    Aug 2005

    Posted 04 Oct 2006 Link to this post

    Natalie,

    Thanks for the explanation and the update. I've run into a few more things "post-update" that probably need to be looked at:

    • The Advanced Search button needs to have "CausesValidation" set to false. It currently cannot be clicked when you are in Forum Reply mode because the RequiredFieldValidator on the reply editor is blocking the action.
    • The main telerik navigation is wrapping on some pages (like this one). When it wraps, the Client.net button appears right below the Products button.
    • On some pages, the sub menus (like Purchase > Policies > Sub Menu) are appearing with about 20px gap between the parent and child (I can observe the problem on this page in IE6).

    That's all that I've observed so far (except that in this post it appears that the BulletedList changed my post's font). Have fun squashing the bugs. =)

    Thanks~

  16. Natalie Farah
    Admin
    Natalie Farah avatar
    170 posts

    Posted 04 Oct 2006 Link to this post

    Hi Todd,

    Thanks for taking some time to report this bugs and helps fix everything we have missed in the new design of the website. Our webteam will begin fixing them and hopefully soon all problems will be cleared.

    Once again thank you for your involvement.

    Greetings,
    Natalie Farah
    the telerik team
  17. Mostafa Anoosheh
    Mostafa Anoosheh avatar
    462 posts
    Member since:
    Nov 2005

    Posted 05 Oct 2006 Link to this post

    Hello Natalie,
    It may be better if you Expand ASP.NET title in left panel In Product roadmap page.

    Best regards
    Mostafa
  18. Kaloyan Simeonov
    Admin
    Kaloyan Simeonov avatar
    5 posts

    Posted 05 Oct 2006 Link to this post

    Thank you for your suggestion, Mostafa. We will consider it.


    Kind regards,
    Kaloyan
    the telerik team
  19. Brian Cumberledge
    Brian Cumberledge avatar
    44 posts
    Member since:
    Jan 2004

    Posted 06 Oct 2006 Link to this post

  20. Todd Anglin
    Todd Anglin avatar
    2040 posts
    Member since:
    Aug 2005

    Posted 06 Oct 2006 Link to this post

    Good catch Brian! =)

    I'm sure Natalie will be updating that link shortly.

    Thanks~
  21. Kaloyan Simeonov
    Admin
    Kaloyan Simeonov avatar
    5 posts

    Posted 11 Oct 2006 Link to this post


    Thanks for the feedback guys, the link has been fixed.

    Sincerely yours,
    Kaloyan
    the telerik team
  22. Brian Cumberledge
    Brian Cumberledge avatar
    44 posts
    Member since:
    Jan 2004

    Posted 16 Oct 2006 Link to this post

    <admin> this post was moved to r.a.d.controls Q3 release</admin>
Back to Top