~/Telerik.Web.UI.WebResource.axd' is missing in web.config

5 posts, 0 answers
  1. Matthew
    Matthew avatar
    13 posts
    Member since:
    Dec 2008

    Posted 23 Jan 2009 Link to this post

    Greetings,

    I've set up Sharepoint according to the Telerik documentation. I have two seperate RADGrid controls on a page. I can see the grids just fine, however when a user with just "Reader" rights accesses the page the following error occurs. 

    ~/Telerik.Web.UI.WebResource.axd' is missing in web.config RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager

    Why would this happen to people that have read-only access? Any ideas?

    I have a demo on Monday and really need some guideance to troubleshoot this.

    Thank you,

    -Matt

  2. Brian Mains
    Brian Mains avatar
    485 posts
    Member since:
    Oct 2008

    Posted 23 Jan 2009 Link to this post

    Hey,

    Whether the page is read only or not, telerik uses a custom AXD to stream down resources.  If you are using the RadScriptManager, open up the designer, click the smart tag button, and there is an option to automatically add this definition to the web.config file.

    Brian
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Matthew
    Matthew avatar
    13 posts
    Member since:
    Dec 2008

    Posted 23 Jan 2009 Link to this post

    Greetings Brian,

    Thanks for the quick response. After double ckecking the web.config file I found that the following was not present in the HttpHandlers section:

    <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2008.3.1125.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" /> 

    I double checked the set up and it's not part of the MOSS implementation. However, it does show up as a troubleshooting tip if you search for "Telerik.Web.UI.WebResource.axd".

    Again thanks for the quick response.

    -Matt
  5. vvvv
    vvvv avatar
    25 posts
    Member since:
    Aug 2011

    Posted 17 Aug 2011 Link to this post

    Thank you so much. It really saved my time.
  6. Namrata
    Namrata avatar
    1 posts
    Member since:
    Jun 2012

    Posted 22 Jun 2012 Link to this post

    Thanx:) it worked.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017