'~/Telerik.Web.UI.WebResource.axd' is missing in web.config'

2 posts, 0 answers
  1. Karthik
    Karthik avatar
    1 posts
    Member since:
    Nov 2013

    Posted 22 Nov 2013 Link to this post


     I am getting the following telerik configuration error on my page:

    '~/Telerik.Web.UI.WebResource.axd' is missing in web.config. RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager

    I am using windowns 2008 and IIS 7.5.

    I googled for this error,most of the sites suggested to place the config settings under the <httpHandlers> in <system.web> and  <handlers> in <system.webservices>. I checked my config file where I already have the config settings in <handlers> and <httpHandlers>. 

    If anyone have the solution for this to solve, please share it.


  2. Kate
    Kate avatar
    1898 posts

    Posted 25 Nov 2013 Link to this post

    Hi Karthik,

    Regarding the IIS 7.5 try setting the Managed pipeline mode from Integrated to Classic and check how it goes. Note that you should register the handler in both the <system.web> section for IIS 6 and in the  <system.webServer> section. I would suggest that you take a look at the following forum post and a help article to get more details and explanation on how you can resolve this issue.

    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. DevCraft R3 2016 release webinar banner
Back to Top