Telerik.Web.UI on MOSS 2007

3 posts, 0 answers
  1. Speed
    Speed avatar
    3 posts
    Member since:
    Feb 2008

    Posted 25 Feb 2008 Link to this post

    I have installed Telerik Controls on MOSS site as per MOSS_WhitePaper. Following error message is logged in MOSS Log files. Please let me know how to fix this?

    SafeControl load exception:Telerik.Web.UI, Version=2007.3.1323.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4 Exception: Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Thanks
  2. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 27 Feb 2008 Link to this post

    Hello Speed,

    Make sure that you have all necessary assemblies in the GAC or in the bin folder of your SharePoint web application. You need to have Telerik.Web.UI.dll, Telerik.Web.Design.dllTelerik.Charting.dll, and System.Web.Extensions.dll. If one of these files fails to load, MOSS will show the error message you encountered.


    Sincerely yours,
    Peter
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. Shujaat
    Shujaat avatar
    1 posts
    Member since:
    Jan 2015

    Posted 15 Jan 2015 in reply to Peter Link to this post

    I have copies all the dlls described above but still having the same error. 

    SafeControl load exception:Telerik.Web.Design, Version=2011.2.712.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4 Exception: Could not load file or assembly 'Telerik.Web.UI, Version=2011.2.712.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)  

    on MOSS 2007.

    Please guide.
Back to Top