Telerik StyleSheets are not working with IE

2 posts, 0 answers
  1. Telis
    Telis avatar
    1 posts
    Member since:
    Jun 2011

    Posted 03 Jun 2011 Link to this post

    Hello, I've read the threads and know about the IE CSS limitations. But in our case we do not have a lot of stylesheets. All we have is one webapp that uses the telerik controls and 1 small stylesheet (css) file with about 20 selectors. We have pages on our site that display some radgrid controls, radtoolbar, radlistview, radtreeview, radcombobox,radtextbox , radwindow all in one page. For some reason after a while of navigating our site, the radtreeview and radtoolbar loose their styles. The radtreeview does not show the lines connecting the nodes and the radtoolbar displays the buttons vertically instead of horizontally. The rest of the telerik controls look ok. So I want to know if there's a need to utilize the RadStylesheetManager (even though we ONLY have 1 CSS file with 20 selectors). I would also like to know if there's a way to troubleshoot this and find out what might be causing this issue. By the way everything looks great in Firefox.
    Thanks
    TC
  2. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 08 Jun 2011 Link to this post

    Hello Telis,

    Did you try to use the RadStyleSheetManager and observe the appearance of your application when you have the RadStyleSheetManager on your page? Is the IE CSS issue that you mention you are aware of is the one that is described in this blog post? Please take a look at our on-line documentation for the control here. In case this does not help we will need a live url so we can inspect the issue and help you out with a solution.  

    Best wishes,
    Kate
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top