Telerik Services

7 posts, 0 answers
  1. Misty
    Misty avatar
    30 posts
    Member since:
    Feb 2015

    Posted 05 Jul Link to this post

    For weeks, my scheduled tests were running fine. Then all of a sudden they stopped. I checked the Telerik Scheduling Service and Telerik Storage Service and they were both stopped. I restarted them but the next day when I did not receive any test results, I looked and the services were stopped again. I talked with our IT person and he rebooted the server where these services live and I got the same result the next day. Suggestions?
  2. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    253 posts

    Posted 08 Jul Link to this post

    Hello Misty,

    Thank you for contacting us. 

    I am sorry to hear you are facing such an issue. As of what you describe I would suggest you to double check if there are any recent changes applied to your network policies that could affect the Storage and Scheduling services. 

    In addition please generate both application and remote execution logs to investigate if there is anything else that might lead us in the right directions. 

    Thank you in advance for the cooperation. I hope to hear from you soon. 

    Regards,
    Elena Tsvetkova
    Telerik by Progress
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
  3. Misty
    Misty avatar
    30 posts
    Member since:
    Feb 2015

    Posted 14 Jul in reply to Elena Tsvetkova Link to this post

    When I was gathering the logs for you, I took a look at them. I realized that I had changed the location of my tests and that's why they are not running. I think I have it figured out now.

    Thanks!

  4. Misty
    Misty avatar
    30 posts
    Member since:
    Feb 2015

    Posted 14 Jul in reply to Elena Tsvetkova Link to this post

    Actually, I spoke too soon. I'm still having problems. I've copied the event logs from the server. This is the message I'm getting whenever I try to start the scheduling service:

    + System
    - Provider
    [ Name] Telerik Scheduling Service
    - EventID 0
    [ Qualifiers] 0
    Level 2
    Task 0
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2016-07-14T15:26:27.000000000Z
    EventRecordID 23737
    Channel Application
    Computer COMPLYSVR03.comply365.local
    Security
    - EventData
    Service cannot be started. System.AggregateException: One or more errors occurred. ---> System.ServiceModel.AddressAlreadyInUseException: HTTP could not register URL http://+:8009/. Another application has already registered this URL with HTTP.SYS. ---> System.Net.HttpListenerException: Failed to listen on prefix 'http://+:8009/' because it conflicts with an existing registration on the machine. at System.Net.HttpListener.AddAllPrefixes() at System.Net.HttpListener.Start() at System.ServiceModel.Channels.SharedHttpTransportManager.OnOpen() --- End of inner exception stack trace --- at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result) at System.ServiceModel.Channels.CommunicationObject.EndOpen(IAsyncResult result) at System.Web.Http.SelfHost.HttpSelfHostServer.OpenListenerComplete(IAsyncResult result) --- End of inner exception stack trace --- at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions) at System.Threading.Tasks.Task.Wait(Int32 millis...

     

  5. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    253 posts

    Posted 19 Jul Link to this post

    Hello Misty,

    Thank you for all shared details. What I assume based on the log you sent is that you have also made changes in your whole setup and now the scheduling server is not set correctly. Please double check your configuration and let me know if you need further assistance on that. You could also elaborate more on your exact configuration. 

    On the other hand please let me know what happens if you run elevated the scheduling server from the start menu - does it start at all? 

    Thank you in advance for the cooperation! I will be looking forward to hearing from you! 

    Regards,
    Elena Tsvetkova
    Telerik by Progress
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
  6. chris
    chris avatar
    6 posts
    Member since:
    Dec 2015

    Posted 26 Oct in reply to Elena Tsvetkova Link to this post

    I had the same problem, it was the execution server starting at the same time as the service. I delayed the scheduler service on startup and it fixed the problem. 
  7. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    253 posts

    Posted 28 Oct Link to this post

    Hi,

    Thank you, Chris, for sharing your experience. I hope it will be helpful to Misty as well. 

    Regards,
    Elena Tsvetkova
    Telerik by Progress
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
Back to Top
  Cast Your Vote at DevPro Connections! Cast Your Vote at  Win IT Pro Connections!