Telerik Reporting Item Template is missing

2 posts, 0 answers
  1. Nicholas
    Nicholas avatar
    1 posts
    Member since:
    Jun 2016

    Posted 03 Jun Link to this post

    Hi, I need some help getting the Telerik Report to show up when I add a new item to a class library project.

    I have followed this guide completely yet I still cant get the template to show up:

    I am using Visual Studio 2015, and the free trial of Telerik Reporting 2016.


  2. Stef
    Stef avatar
    2926 posts

    Posted 06 Jun Link to this post

    Hi Nicholas,

    Please test the following:
    1. Create a standard ClassLibrary project, not the ClassLibrary(Package)  ASP.NET Core project template.
    2. Select the project note in the VS Solution Explorer and select 'Add New Item' from the context menu;
    3. Find 'Reporting' on the Left side, and then 'Telerik Report R2 2016 Wizard' from list.
    The above must start Telerik Report Wizard in Visual Studio.

    Other approach is to add a new project, and to select Telerik Report Library R2 2016.

    In case templates are still missing, please check if the installed Visual Studio and the machine cover Telerik Reporting System Requirements. Then test to uninstall and re-install by using the MSI file and running the command suggested in Installation Problems.

    Let us know how it goes. Also feel free to open a support ticket and to send us the generated log file.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
Back to Top