Telerik.Reporting.Graph line : How it work ???

2 posts, 0 answers
  1. Pierre
    Pierre avatar
    11 posts
    Member since:
    Mar 2016

    Posted 18 Aug Link to this post

    Hi,

    I Try since 2 day to make working a Line graph in a report !

    I don't understand HOW IT WORK...

    I was thinking that would be simple on reading documentation (http://docs.telerik.com/reporting/graphhowtocreategraphwithcolumnandlineseries and others docs) but..... it is not.

     

    See in screen shots attached the report Design, the Datasource during execution, ........ and the Result !?

    I don't understand how it work !

    I have a similar graph in RadthmlChart and it work with the same data.... Why doesn't work in reporting graph ??

     

    I expect a result like Telerik_Report_Graph_Result_ok.png

    THANK YOU FOR YOUR HELP

     

  2. Katia
    Admin
    Katia avatar
    305 posts

    Posted 18 Aug Link to this post

    Hi Pierre,

    When fetching the data via NeedDataSource event the design time preview of the Graph will not be available. If you want to be able to see the design time preview the workaround is to mock the data - Working With Data at Design Time (Data source available only at runtime).

    Also, NeedDataSource event fires only when the data item has no DataSource - Using the NeedDataSource event to connect data. Keep in mind that, inside the event handlers, you should work with processing item - Understanding Events

    With properties LabelUnit and LabelStep you can control the number of XAxis labels shown - Formatting Graph Axis.

    Sample settings of Line chart are provided in the attached report.


    I hope this will be helpful.

    Regards,
    Katia
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
Back to Top