Telerik Reporting DLL issue with Unicode Character

4 posts, 0 answers
  1. mayank
    mayank avatar
    11 posts
    Member since:
    Sep 2012

    Posted 19 Oct 2013 Link to this post


    I Am Using Telerik reporting DLL for Export PDF .

    But When I export data With Unicode Character Not Support in PDF.

    for E.X => Original String  ==>  PѐrustamismэnoЁcoToPat 520
                        In  PDF               ==>  P􀀀rustamismэnoЁcoToPat 520


    unicode Character not supported.

    please help us

    Thanks in advance

  2. Ivan Hristov
    Ivan Hristov avatar
    85 posts

    Posted 21 Oct 2013 Link to this post

    Hello Mayank,

    You are probably using a font which cannot be substituted correctly or is not installed on the server where the PDF generation is executed. The string "PѐrustamismэnoЁcoToPat" that you used as an example in your previous post is exporting without any problems using the default Arial font.

    Please take a look at this documentation article for more information:
    Ivan Hristov

    Have you tried the new visualization options in Telerik Reporting Q2 2013? You can get them from your account.

  3. UI for ASP.NET AJAX banner
  4. Srujal
    Srujal avatar
    1 posts
    Member since:
    Nov 2011

    Posted 17 Feb Link to this post

    hi i am using telerik.reporting.dll version = When i try to build my solution there is a compile time error stating

    'Could not load file or assembly 'Telerik.Reporting, Version=, Culture=neutral, PublicKeyToken=a9d7983dfcc261be' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)'

    event though i have add its references

  5. Stef
    Stef avatar
    2914 posts

    Posted 18 Feb Link to this post

    Hello Srujal,

    Please check if the assembly mentioned in the error is copied locally in the application's Bin folder. The assembly can be copied in the Bin folder through Visual Studio - select the references to Telerik Reporting assemblies and set their CopyLocal to true in the PropertyGrid.

    If it is a WebSite project, check where assemblies are loaded from through the WebSite project's Property Pages, and verify it is the Bin folder, not the machine's GAC.

    I hope this information helps.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
UI for ASP.NET AJAX banner