Telerik RadEditor

8 posts, 0 answers
  1. Monica
    Monica avatar
    4 posts
    Member since:
    Aug 2012

    Posted 28 Aug 2014 Link to this post

    I use RadEditor in Visual Studio C# for publishing in SharePoint.
    The version is 2014.1.403.45. When I deploy  is impossibile open the dialog DocumentManager for attach documents in my textbox.
    The error is "Web.config registration missing.....", but the registration is done.

    The dialog box show the message "404 not found" and path in the proprieties is

    http://xxxxxxx/xxxxxxx/_catalogs/masterpage/Telerik.Web.UI.DialogHandler.aspx?DialogName=DocumentManager&Skin=Default&Title=Document%20Manager&doid=c3ff2457-1492-47d3-b822-44e767fe68c4&dpptn=&isRtl=falseWhat wrong?

    Thank you

    Monic

  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 02 Sep 2014 Link to this post

    Hello Monic,

    If you are using the RadEditor WebPart as a custom WebPart for SharePoint, make sure that the dialogs are configured correctly in the web,config file of the SharePoint application as per to the guidelines mentioned in this KB article.

    On a side note, when it comes to SharePoint, we always recommend using the especially designed RadEditor WebPart for SharePoint which is part of the Telerik WebParts for SharePoint suite.

    Regards,
    Ianko
    Telerik
     
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
     
  3. Monica
    Monica avatar
    4 posts
    Member since:
    Aug 2012

    Posted 02 Sep 2014 in reply to Ianko Link to this post

    Thanks for your reply.
    I had already checked the KB Article.
    I should post more RadEditor in a page, so I do not think RadEditor WebPart for SharePoint is the right solution.
  4. Monica
    Monica avatar
    4 posts
    Member since:
    Aug 2012

    Posted 02 Sep 2014 in reply to Monica Link to this post

    ..continue
    I can't create webpart for every text section. My purpose is save every section in a sql field.
  5. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 03 Sep 2014 Link to this post

    Hello Monica,

    To enable the dialog in custom WebParts consisting of the RadEditor control, you should properly configure the appropriate handlers, as explained in the KB. If you still have issues, I suggest verifying the correctness of the web.config registrations and that they match the correct version of the fully qualified names. 

    Note, that the RadEditor WebPart is built as a custom WebPart. Due to that I do not see what is the difference if a custom one is used or t he already built and provided. Adding it to a SharePoint page is simple as the custom WebParts. Ones installed and enabled, you need only to add it as a WebPart in the possible placeholders.

    Regards,
    Ianko
    Telerik
     
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
     
  6. Enrico
    Enrico avatar
    10 posts
    Member since:
    Oct 2011

    Posted 06 Oct 2014 in reply to Ianko Link to this post

    Hello Ianko,
    I've used RadEditor for ASP.NET AJAX in a SharePoint web part and I've seen the same problems Monica told you.
    I have a couple of questions:
    1) Is it possible to use this control within a SharePoint web part. I need to be able to attach documents. Is there a way to make this functionality work. 
    2) I've also tried using SPRadEditor but I cannot configure toolbar buttons. It seems not possible. Is there a way to do it?
       Again I would need the attachment functionality.
    Regards

    Enrico


  7. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 08 Oct 2014 Link to this post

    HelloEnrico,

    You can use the RadEditor from the Telerik UI for ASP.NET AJAX suite for custom WebParts in SharePoint and to enable the Document Manager, you should configure properly the web.config of the SharePoint application and the RadEditor's DialogHandlerUrl property as per to the suggestions in the provided KB article.

    I.e.:

    1. Add the needed handlers (WebResources.axd,  DialogHandler.aspx etc.) in the web.config of SharePoint;
    2. Make sure to add the fully qualified names according the used version;
    3. Replace the DialogHandler.aspx with DialogHandler.axd to be valid for the SharePoint environment;
    4. In the RadEditor, set the DialogHandlerUrl to "~/Telerik.Web.UI.DialogHandler.axd".

    However, I would recommend using the already designed for SharePoint SPRadEditor. It's Link Manager is the one that SharePoint natively provides and it best fits the needs in SharePoint. It is enabled by default and it should appear in the toolbar as expected (see this screenshot).This dialog provides the functionality to link documents that already present in SharePoint's file collections, including the documents.

    If you need to use the built-in Document Manager of the RadEditor, you can reconfigure the ToolsFile of the SPRadEditor and enable it. Note that using the SPRadEditor class in custom WebPart again uses the ToolsFile.xml file to populate the tools. You can follow this help article for additional details about modifying the ToolsFile. To enable the Document Manager just add the following line in any of the tools sections of ToolsFile.xml file:

    <tool name="DocumentManager" />

    Regards,

    Ianko
    Telerik
     
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
     
  8. Enrico
    Enrico avatar
    10 posts
    Member since:
    Oct 2011

    Posted 08 Oct 2014 in reply to Ianko Link to this post

    Hello Ianko,
    thank you for your quick answer.
    I followed your suggestion and implemented the solution using SPRadEditor.
    It does exactly what I need!
    Thank you very much!

    Kind Regard

    Enrico


Back to Top