Telerik controls do not show up in VS-2010 after installation...

13 posts, 0 answers
  1. Yan Moura
    Yan Moura avatar
    33 posts
    Member since:
    Feb 2010

    Posted 20 Jun 2011 Link to this post

    Hi!

    After to struggle trying to make Rad controls show up in Toolbox, I finally sort it out by resetting the toolbox.
    Now the problem is with the Treeview control that is not in the list.
    Any clue?

    Thanks!
  2. Yan Moura
    Yan Moura avatar
    33 posts
    Member since:
    Feb 2010

    Posted 20 Jun 2011 Link to this post

    Actually it IS in the list (toolbox), but when I drag it to my project, the following message error box pops:

    Type universe cannot resolve assembly: Telerik.Windows.Controls, Version=2011.1.315.1040, Culture=neutral, PublicKeyToken=5803cfa389c9c0e7<br>

    I can see the Telerik.Windows.Controls and Telerik.Windows.Controls.Navigation in my project references branch.

    I tried to remove and reattach the references manually, tried to close VS and open it again, but nothing worked.

    Thanks!
  3. DevCraft banner
  4. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 21 Jun 2011 Link to this post

    Hi Yan Moura,

    It seems that the RadControls available in the toolbox have different version than the version of your project references. For the proper work of the toolbox controls their version must match the version of the Telerik references in the project.

    You can check what is the version of the RadControls in the toolbox from the Toolbox Configurator (started from the Telerik menu, then RadControls for Silverlight -> Launch Toolbox Configurator). The current version is displayed on the right side. If the version of the references differs from the one of the toolbox, please update the toolbox to the correct version by selecting the new version from the combo box and pressing finish. The update will restart your Visual Studio automatically, restoring the loaded solution.

    You can check if that works by creating a blank RadControls Silverlight Application and performing a drag and drop of the TreeView again.

    If you have any questions or problems, feel free to contact us.

    Regards,
    Chavdar
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Yan Moura
    Yan Moura avatar
    33 posts
    Member since:
    Feb 2010

    Posted 21 Jun 2011 Link to this post

    Hi Chavdar,

    Thanks for answering!

    There is something you have mentioned in your last message that puzzled me a little. You said: "You can check if that works by creating a blank RadControls Silverlight Application and performing a drag and drop of the TreeView again."

    OK, so after to check the RadControls version and ensure that the version was correct, I created a new blank "C# RadControls Silverlight Application" to see what happens, and then I notice that I am able to add the two Rad components I need (RadTreeView and RadComboBox). I don't get any error message, any compiling error and the new application builds OK. Everything is good. Well, ALMOST good.

    The problem is that I am not going to start a new application from scratch. I have an existing Silverlight application that I need to replace a couple of its standard components by the Rad ones, and seems that maybe THIS is the cause of the issues (because it is not a "RadControls Silverlight Application", but a "Silverlight Application").

    How can I figure this out, in this case? I think that is a bit crazy to imagine that RadControls will work only in applications created as "Rad applications" because in this case, what will I do with all my existing apps that I want to enhance with RadControls? I would have to remake all my work again????

    Could you please try to help me to figure this out?

    Thanks!

    Yan
  6. Yan Moura
    Yan Moura avatar
    33 posts
    Member since:
    Feb 2010

    Posted 21 Jun 2011 Link to this post

    Hi Chavdar,

    That's me again.

    I have more details, if it will help to find the solution for my problem.

    I went to menu Telerik >> RadControls For Silverlight >> Configure Project and opened the "Project Configuration Wizard".
    There I can see the two new references that were added to my project:

    Telerik.Windows.Controls
    Telerik.Windows.Controls.Navigation

    However they have a warning icon (the yellow triangle plate with the exclamation mark inside).
    Mousing over the icon, it tells me a long message:

    "Correspoinding Telerik.Windows.Controls.Design, Telerik.Windows.Controls.Expression.Design, Telerik.Windows.Controls.VisualStudio.Design.4.0, Telerik.Windows.Controls.VisualStudio.Design assemblies not found! Design time could be broken!"

    Thanks,

    Yan

  7. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 22 Jun 2011 Link to this post

    Hello Yan,

    Thank you for the update.

    It is possible to add RadControls to existing Silverlight application. The easiest way to do this is to use the Convert Wizard - you can start it from Telerik >> RadControls For Silverlight >> Convert to Telerik Silverlight Application. Here is an example how to do this: http://www.telerik.com/help/silverlight/radcontrols-for-silverlight-vs-extensions-project-configuration.html. This approach should work for applications that do not contain any Telerik references.

    I guess that the problems in your case are caused by references, that are not part of a complete distribution. You can try to remove them and then use the Convert Wizard for adding the necessary references by selecting one of the installed or downloaded distributions.

    If you still get the same problem, could you please describe the exact steps that you perform to get it and what you receive, i.e. any message or exception?

    Looking forward to hearing if that helped.

    Best regards,
    Chavdar
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Yan Moura
    Yan Moura avatar
    33 posts
    Member since:
    Feb 2010

    Posted 22 Jun 2011 Link to this post

    Hi Chavdar,

    Thanks for helping, but... still no luck!

    Let me describe step-by-step what I am doing and what is going on.

    1) Opened my project (name is PMPI) in VS

    2) Telerik >> RadControls For Silverlight >> convert to Telerik Silverlight Application

    3) So I browsed to the folder where there is my Telerik package and then they showed up
    Program Files/Telerik/RadControls for Silverlight Q1 2011/Binaries/Silverlight/

    4) So I checked Telerik.Windows.Controls and Telerik.Windows.Controls.Navigation and clicked 'Finish'

    5) Then the two new ones appeared in my project "References"

    6) Then I opened toolbox and dragged RadTreeView to my PMPI.xaml file

    7) Then I stroke F5 to run/debug it. ISSUES STARTED AT THIS POINT.

    Visual studio then raised two errors in the Error list:
    "Error    1    The type or namespace name 'RadTreeView' could not be found (are you missing a using directive or an assembly reference?)    C:\Documents and Settings\yan\My Documents\Visual Studio 2010\Projects\PMPI\SimpleHttpPost\obj\Debug\PMPI.g.cs    64    18    PMPI"

    "Error    2    The type or namespace name 'RadTreeView' could not be found (are you missing a using directive or an assembly reference?)    C:\Documents and Settings\yan\My Documents\Visual Studio 2010\Projects\PMPI\SimpleHttpPost\obj\Debug\PMPI.g.cs    91    35    PMPI"

    OK, easy fix - I went to the PMPI.g.cs and added in the top of code:

    using Telerik.Windows.Controls;

    8) OK, errors were gone. Let's try to run/debug again!

    9) Stroke F5 and another issue. This time VS launched IE but then came back to VS with a runtime error at the code line that says "InitializeComponent()":

    "Unknown namespace http://schemas.telerik.com/2008/xaml/presentation. [Line: 21 Position: 111]"

    10) At this point I stopped debugging.

    11) Telerik >> RadControls For Silverlight >> Configure project

    12) It showed the two controls added to References, but both has that small yellow triangle sign that says "Correspoinding Telerik.Windows.Controls.Design, Telerik.Windows.Controls.Expression.Design, Telerik.Windows.Controls.VisualStudio.Design.4.0, Telerik.Windows.Controls.VisualStudio.Design assemblies not found! Design time could be broken!"

    Apparently it still cannot find the controls... Any idea?

    Thanks,

    Yan
  9. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 23 Jun 2011 Link to this post

    Hi Yan,

    I tried to reproduce the problem but the Convert Wizard works for me.

    How about a GoToMeeting session? I hope I will be able to help by checking the situation directly on your machine.

    Please, suggest a convenient time if that appropriate. We are based in Europe (EET, GMT+2).

    Best regards,
    Chavdar
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Rajesh
    Rajesh avatar
    8 posts
    Member since:
    Apr 2012

    Posted 23 Apr 2012 Link to this post

    how did you make telerik controls viewable in vs2010 toolbox?
    please reply me as quickly as possible

    thanks in advance
  11. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 24 Apr 2012 Link to this post

    Hello Rajesh,

    After successful installation the controls should be available in the toolbox when you open a Silverlight 5 form.

    In case they do not appear, please follow the instructions in the next article to add them manually: http://www.telerik.com/help/silverlight/installation-adding-to-vs-2010-toolbox.html

    I hope this will help. Please, do not hesitate to write back if you have any further questions.

    Best regards,
    Chavdar,
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  12. Rajesh
    Rajesh avatar
    8 posts
    Member since:
    Apr 2012

    Posted 24 Apr 2012 Link to this post

    Hi Chavdar Dimitrov,

    Thank you for your reply,

    But still my issue not getting clear as i tried url(http://www.telerik.com/help/silverlight/installation-adding-to-vs-2010-toolbox.html) steps.

    issue here im getting is "Telerik.Wndows.Controls.Navigation.Dll is not getting add when i try to browse and add as reference".

    Exception Details:
    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Could not load file or assembly 'System, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.
    ---------------------------
    OK  
    ---------------------------
    and im currently using VS2010 and silverlight 4.0 version.

    exception is releted to silverlight version?
    Thank you.
  13. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 24 Apr 2012 Link to this post

    Hello Rajesh,

    The RadControls for Silverlight version you've downloaded installs our Silverlight 5 controls. Since Q1 2012 the automatic installer provides Silverlight 5 controls only and I would suggest you to use this version.

    Still, if you need Silverlight 4 controls, you can download a hotfix (Silverlight 4 - DLLs only) from the RadControls for Silverlight download page (link: http://www.telerik.com/account/your-products/trial-product-versions/trial-single-download.aspx?pmvid=2754&pid=571) which contains the Silverlight 4 controls.

    In order to populate the controls in the toolbox, please follow the steps from my previous post.

    Kind regards,
    Chavdar,
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  14. Rajesh
    Rajesh avatar
    8 posts
    Member since:
    Apr 2012

    Posted 24 Apr 2012 Link to this post

    Hi Chavdar Dimitrov,
    Thank you so much for your immediate response.

    Rajesh KS
Back to Top
DevCraft banner