switch to html

4 posts, 0 answers
  1. Amith S
    Amith S avatar
    10 posts
    Member since:
    Dec 2009

    Posted 09 Mar 2010 Link to this post

    Hi,

    I have added a 'add video' button to the editor. I am allowing members to add youtube or google video's to the forum. I am using the embed tag to do this. Also i am using editor.pasteHtml function and it inserts it fine.

    The problem is that when insert.pasteHtml is called, the editor is in design view and nothing appears. Only when i switch manually to Html mode i see the code and when i switch back there is a big flash symbol.

    Users will need some way on knowing the video has been inserted, I was thinking if there is a way to switch from design to html and back so that the flash may appear. Hoping some function like editor.switchhtmlmode or editor.switchdesignmode.

    If there is another way to accomplish this, ideas are most welcome.

    Thanks,
    Amith
  2. robertw102
    robertw102 avatar
    265 posts
    Member since:
    Jul 2007

    Posted 09 Mar 2010 Link to this post

    This help article shows you how to switch editor modes.


    I hope that helps.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Rumen
    Admin
    Rumen avatar
    12848 posts

    Posted 09 Mar 2010 Link to this post

    Hi,

    The MozillaKeepFlashString filter code provided in this forum thread could be helpful too for your scenario:
    Problems with ConvertToXhtml Filter and <object> tag.

    Regards,
    Rumen
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Amith S
    Amith S avatar
    10 posts
    Member since:
    Dec 2009

    Posted 18 Mar 2010 Link to this post

    thank u robertw102  and Rumen
Back to Top