Support for Npgsql v3

2 posts, 0 answers
  1. Arnaud
    Arnaud avatar
    25 posts
    Member since:
    Jan 2013

    Posted 09 Dec 2015 Link to this post


    I think you don't support Npgsql v3. After update my nuget package in my project with 3.0.4, I have an error :

    Couldn't load 'NpgsqlTypes.NpgsqlTimeZone' in assembly 'Npgsql, Version=, Culture=neutral, PublicKeyToken=5d8b90d52f46fda7'

    Have you plan to support this new branch ? Because v2 is going to be deprecated and I think I am not the first (and the last) I update my nuget package without remark this break.

    Thanks in advance

    PS : A support of v3.1 could be a first step for .NetCore compatibility of DataAccess, it could be nice ;)

  2. Viktor Zhivkov
    Viktor Zhivkov avatar
    290 posts

    Posted 14 Dec 2015 Link to this post

    Hello Arnaud,

    Thank you for the suggestion.
    At the moment we do not have clear plan when we will be able to ship official support for the latest version.
    We are giving priority for backend systems required by Telerik Sitefinity (like Microsoft SQL Server, Oracle and MySQL) and if we have time and development power we may push your request through. Still please, do not treat that as promise.

    If there is any progress I will make sure to notify you.

    Viktor Zhivkov
    Check out the latest announcement about Telerik Data Access vNext as a powerful framework able to solve core development problems.
  3. DevCraft banner
Back to Top