Support for NativeScript 1.1 (or 1.2)

13 posts, 1 answers
  1. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 22 Jul 2015 Link to this post

    Hi.

    Is there any news ​on when the AB Windows client will be updated so that native apps can be developed using NativeScript v1.1?

    I appreciate there's always a ​delay before AB supports the most recent version of {N} but v1.1 was released five weeks ago now and yet AB is still using {N} v1.0.1.

    Regards, Ian

  2. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 24 Jul 2015 Link to this post

    Hi Ian,

    I am glad to say that, the support for NativeScript 1.1.2 in AppBuilder will be released with the upcoming AppBuilder 2.11 version next week. Then, you will be able to create new or migrate present NativeScript projects to the above mentioned version. The only thing you must have in mind is the fact that any NativeScript custom modules will be lost during the migration from 1.0.1 to 1.1.2.

    I hope this helps.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 24 Jul 2015 in reply to Kaloyan Link to this post

    Hi Kaloyan,

    Thanks - that's good news. Out of interest, I see {N} 1.2 is due to be released on Aug 4th. Has a date been set for when AB will support that version?

    Regards,Ian 

  4. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 29 Jul 2015 Link to this post

    Hi Ian,

    It is in our plans to develop support for NativeScript 1.2 in AppBuilder 2.12, scheduled for September. Still, could you please share if there is anything specific you need from that {N} version?

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  5. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 29 Jul 2015 in reply to Kaloyan Link to this post

    Hi Kaloyan,

    I think support for extended CSS properties and the new HtmlView component would be the {N} 1.2 features I'd like to see first. After that the ActionBar and any debugging improvements would come second.

    Hope that helps, 

    Ian

    .

  6. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 03 Aug 2015 Link to this post

    Hi Ian,

    You should be able to use those, by updating the tns modules in your project. As for debugging improvements, I am afraid you will have to wait our official release.

    I hope this helps. Thank you once again for the valuable feedback.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  7. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 03 Aug 2015 in reply to Kaloyan Link to this post

    Hi Kaloyan,
    Thanks for the suggestion. I did try setting up a tns environment some time ago only to realise that because we only have Windows systems here (ie. no Macs), we’d only ever be able to use the CLI dev route for Android. I think that was one of the reasons we found the AB option attractive as it allowed us to develop for Android and iOS using just Windows dev systems. I’m guessing that restriction is still there?

    Is it possible to download a v1.2 tns_modules folder and use that to replace the v1.1 folder in an AB {N} app? Just to see if it worked, I did try downloading the tns_modules folder from the {N} sample-groceries app but my app failed to load. The error message was ‘Failed to enum files for folder…’. Error: Actual arguments count 1, Expected 2. Are there are other v1.2 files I’d need to download or am I trying to do something that’s not possible?

    Best regards, Ian

  8. DEA
    DEA avatar
    8 posts
    Member since:
    Jul 2015

    Posted 04 Aug 2015 in reply to Kaloyan Link to this post

    I'd like to use Telerik UI for NativeScript as well :)
  9. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 06 Aug 2015 Link to this post

    Hello guys,

    We are planning to release an update of AppBuilder specifically targeting the support for NativeScript 1.2. The release is expected out in about 2 weeks although I cannot yet commit to an exact date.

    @Ian - As for updating the tns_modules in your AppBuilder project, I would recommend that you use the NativeScript CLI to create a new sample project through the tns create <AppName> command. This will generate a sample NativeScript project from which you can copy the files from under the tns_modules directory and move them inside your AppBuilder project. I tested this approach on my side and I was able to create a sample app that uses the HtmlView and run it on an Android device. If you need any help with it, I would ask you to create a support ticket and attach your project so we can update it for you.

    Also, please keep in mind that in a more elaborate application scenario these modules might need the latest iOS and Android NativeScript runtime environment to work properly. This is why until AppBuilder officially supports NativeScript 1.2, I cannot guarantee your app will work as expected. 

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  10. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 07 Aug 2015 in reply to Tina Stancheva Link to this post

    Hi Tina,

    Thank you for the comprehensive reply. I did try creating a sample project using the {N} CLI and copying over the contents of the tns_modules folder to a Hello World-templated app I created in AB but I got the same error message when running on iOS and with Android it reported the app had stopped working. I'm going to be on vacation ​shortly so ​as you're planning a new AB release with {N} 1.2 support ​later this month I think it will be easier to wait for that. Thanks again though for ​investigating a workaround - it's appreciated.

    Best regards, Ian

  11. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 28 Aug 2015 in reply to Ian Link to this post

    As a postscript – and in case it helps anybody else experiencing a similar issue – the reason I still encountered problems after manually updating the {N} tns_modules files to a later version was that there was also a {N} version dependency in the Telerik companion app. Once a new version of this was released that supported {N} 1.2.X, my own app worked.
  12. Answer
    Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 02 Sep 2015 Link to this post

    Hi Ian,

    Thank you for the feedback.

    Further, since AppBuilder 2.11.3 you can now develop applications with {N} 1.2.3. Also, you can migrate your existing {N} 1.1 project, following the steps from this article. I hope this helps.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  13. nimi
    nimi avatar
    1 posts
    Member since:
    Jan 2016

    Posted 25 Jan Link to this post

    nice post
Back to Top