Summer theme implicit styles causing crash on designer.

4 posts, 1 answers
  1. Marcin
    Marcin avatar
    165 posts
    Member since:
    Jan 2011

    Posted 25 Apr 2013 Link to this post

    Hello,
    I'm mainly using Summer theme as implicit styles. However I realized that System.Windows.xaml of this theme is causing exception in WPF designer on Visual Studio 2012. When I'm exclude these styles from resources everything is correct, after including I have crash again. I've started testing and realized that this is happening with summer theme but e.g. Windows8 is working without issue. I've checked office and it has the same issue. The issue is only with System.Windows.xaml  file. I tried to find where it is but I couldn't

    There is other issue that I have which is related to .NET 4 and Visual Studio 2010:
    in your implicit styles there can be found e.g. following clause:
    <DiscreteObjectKeyFrame.Value>
    <Thickness>0,0,-1,0</Thickness>
    </DiscreteObjectKeyFrame.Value>
    Becaue I'm using Polish operating system designer (becuase of VS bug) cannot parse this (it doesn't like commas). Could you please change commas to spaces? Which is proper as well and you already using that in most places but not always. I can find examples where commas can be found. It is taking me a lot of time to upgrade project properly becuase I need to take care with this bug.
  2. Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 29 Apr 2013 Link to this post

    Hi Marcin,

     

    Thank you for reporting this issue! We were able to reproduce it and we will do out best to provide a fix for this design-time exception in one of our next internal builds. If you are wondering what happens I can say that the problem is related to the ScrollBar style in our themes. As per your second question - we had an internal discussion about your request. We spent some time to investigate it and mostly  this is a problem related to Microsoft, not to Telerik. Rather fortunately they fixed this one with Visual Studio 2012. If you give it a try you may see that there is no difference whether you use commas or spaces as delimiters. For the time being I may suggest you to use the Visual Studio 2012, where such a behavior cannot be observed. As a kind of workaround you may also try to change the culture settings of your OS to English in case you are using VS 2010. 



    I am also updating your Telerik points accordingly! 



    Kind regards,
    Vanya Pavlova
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. UI for WPF is Visual Studio 2017 Ready
  4. Marcin
    Marcin avatar
    165 posts
    Member since:
    Jan 2011

    Posted 29 Apr 2013 Link to this post

    Hello,
    Thank you for answer.

    Some information for you maybe will be helpfull:
    1) First bug only occurs in Visual Studio 2012 in Visual Studio 2010 it is not existing.
    2) I was able to find this bug by adding TextBox to the window. Adding CheckBox or RadButton or even using RadWindow didn't cause 1st error. Only TextBox did (but I've made only simple test). That's why it is abit supprising that problem is with Scroll :) But maybe it is related.
    3) I know second bug is related to Visual Studio, and I know it is fixed in 2012.
    4) I do not want to change regional setting becuase I'm using Polish CSV files and after change it will stop working. So changing regional settings is not an option.
    5) I replaced commas with spaces and now I can use designer in Visual Studio 2010. But like I was written the problem is with every update I have to that manually. That's why my suggestion was to change this in generic files. This is only few such occurences (I think less than 10) at least in files I've checked (navigation, controls, input).  This commas are only exitsing in controls with drop downs. For example in Telerik.Windows.Controls.GridView.xaml there are already spaces not commas. So it is even inconsistent within your own files. eg:
    <ObjectAnimationUsingKeyFrames Storyboard.TargetName="IconInnerBorder" Storyboard.TargetProperty="BorderThickness">
                 <DiscreteObjectKeyFrame KeyTime="00:00:00">
                   <DiscreteObjectKeyFrame.Value>
                     <Thickness>1 1 0 0</Thickness>
                   </DiscreteObjectKeyFrame.Value>
                 </DiscreteObjectKeyFrame>
               </ObjectAnimationUsingKeyFrames>
    That's why my suggestion was to make it the same everywhere and use spaces.
  5. Answer
    Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 01 May 2013 Link to this post

    Hi Marcin,




    Thank you for sharing your thoughts with us! As you know we always appreciate customer feedback in order to improve the quality of our components. As per the problem with the ScrollViewer, the exception occurs with the TextBox, because it internally uses System.Windows.ScrollViewer. By that reason the problem could not reproduced either with a single Button or RadioButton. As promised we will do our best to provide a fix for this in one of our next internal builds or for our next official release (Q2 2013), but not later. While discussing the problem with the delimiters we came to the conclusion that we should replace not only the commas within Storyboard animations, but all properties of Type Thickness within the templates should use spaces, rather than commas and the count of these symbols is more than 1100 for all components as part of the control suite.


    Have a great day!


    Kind regards,
    Vanya Pavlova
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top